summaryrefslogtreecommitdiff
path: root/app-office/dia2code/dia2code-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-office/dia2code/dia2code-1.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-office/dia2code/dia2code-1.0.0.ebuild')
-rw-r--r--app-office/dia2code/dia2code-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/dia2code/dia2code-1.0.0.ebuild b/app-office/dia2code/dia2code-1.0.0.ebuild
new file mode 100644
index 000000000000..627ca3ef520d
--- /dev/null
+++ b/app-office/dia2code/dia2code-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours"
+HOMEPAGE="http://dia2code.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="${DEPEND}"
+DEPEND="
+ dev-libs/libxml2
+ test? ( app-shells/bash )
+"
+
+src_prepare() {
+ # Script makes use of arrays
+ sed -e 's:/bin/sh:/bin/bash:' \
+ -i tests/tests.sh || die
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ doman docs/dia2code.1
+}