summaryrefslogtreecommitdiff
path: root/app-mobilephone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-mobilephone
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/Manifest.gzbin2217 -> 2216 bytes
-rw-r--r--app-mobilephone/dfu-util/Manifest4
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.11.ebuild27
-rw-r--r--app-mobilephone/dfu-util/dfu-util-9999.ebuild12
4 files changed, 36 insertions, 7 deletions
diff --git a/app-mobilephone/Manifest.gz b/app-mobilephone/Manifest.gz
index 37224620352c..c4b9a53bd047 100644
--- a/app-mobilephone/Manifest.gz
+++ b/app-mobilephone/Manifest.gz
Binary files differ
diff --git a/app-mobilephone/dfu-util/Manifest b/app-mobilephone/dfu-util/Manifest
index 40427e7bbb72..11790ad988e7 100644
--- a/app-mobilephone/dfu-util/Manifest
+++ b/app-mobilephone/dfu-util/Manifest
@@ -1,4 +1,6 @@
+DIST dfu-util-0.11.tar.gz 152462 BLAKE2B 3734698dd62de8a1c781f7631ae17ee9755241ce4d614b028fe6d6c3a117f3a301c174dcadf52252d55b08cfd75298c27a588e880837317ff73c32ab8863ccdd SHA512 fc5304a483ac10e35bf1b9304becdeb407b2e44d8ac51474d2fa17877e6cf71b0126f7e12ebb331d75e7adeb9c173ff5cf083a06ded5847dbe477534cf26a553
DIST dfu-util-0.9.tar.gz 138397 BLAKE2B e3a9db3276204d25fbcdd7d50caacd28a8e043d2781b5f942cd0df343d046870003abeaa1005a2774d03c4198ce96fa2124040987069c5f444e36e4f365a5e0e SHA512 caa7148b7a9004e2b1f7bc4f1a26b48abfe311743bc0eeed1ab57459910371affc39b6fe7e74b7cac6ca9de41a9901b7a970253ca92d7d66d5008f8a11d2c952
+EBUILD dfu-util-0.11.ebuild 617 BLAKE2B 47e3d3d28b1e22d26ea01b2ffc2b07987940877038463607b316a7f2d30e2bd9896f5df06bac07672f4d3489d0511bc4c8690702f19a81d4126a5b88795e3641 SHA512 7b992b0c8b4a73eb8ca435010564c937439ff37607b30d8446c95cc9d3adfa2200325a5c337ce42b43b80074bf8161e62de1a95c5b8033f86cfb019879651dcd
EBUILD dfu-util-0.9.ebuild 611 BLAKE2B 1684c27777969c7aefefa831a4f93b1e58bee27042d2f57d026aaa3cc8a71597211fad44ee5b7763c22ba307bb6fac6b89318ccaf94998673eccc2f9e536774b SHA512 3df4947a9180bdd44cf3125dfa3d4f8cf4aed05b45397a7365a42de045dc7ed3ce12e2f6c1ae5f0fa5b317fcd0501ee8a40dae514af6baaae48df39cd9eea46f
-EBUILD dfu-util-9999.ebuild 613 BLAKE2B f36bfa2685a0c2ae90a0dae5df42f99a181c9314b4c8d952150e76c6144ecf174693157ee897b281213fb570aa085b8197e18b260a09bcbab8102d5664c2d068 SHA512 6cf5538e2f99326a922767631402887324a7395788bc3435ed410d65b8fa0735ac6fb9414e1ff61f8584f128ce1a992dc3ee1df4c97fb1cc540b7db1edd98727
+EBUILD dfu-util-9999.ebuild 617 BLAKE2B 47e3d3d28b1e22d26ea01b2ffc2b07987940877038463607b316a7f2d30e2bd9896f5df06bac07672f4d3489d0511bc4c8690702f19a81d4126a5b88795e3641 SHA512 7b992b0c8b4a73eb8ca435010564c937439ff37607b30d8446c95cc9d3adfa2200325a5c337ce42b43b80074bf8161e62de1a95c5b8033f86cfb019879651dcd
MISC metadata.xml 330 BLAKE2B 8dd6ce23111123463d3a9585b1fdff4cdf8a7670803dc36c007daa02796e764a29eff3b420dba2651e8812ae39d7df0a7de6f20a10ad5447c0b799074346fb42 SHA512 fb9646c59340854d13fb4f82e13f467a34090eb629937cf846c9db1a6ed2095d9bf6456741e6ba3460709d95f9a36bc6bdbc6063492eb5222330190b52c961df
diff --git a/app-mobilephone/dfu-util/dfu-util-0.11.ebuild b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
new file mode 100644
index 000000000000..0f4c6cd5a619
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
diff --git a/app-mobilephone/dfu-util/dfu-util-9999.ebuild b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
index 9c3ac27b12b1..0f4c6cd5a619 100644
--- a/app-mobilephone/dfu-util/dfu-util-9999.ebuild
+++ b/app-mobilephone/dfu-util/dfu-util-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
inherit autotools git-r3
else
@@ -18,10 +18,10 @@ LICENSE="GPL-2"
SLOT="0"
RDEPEND="virtual/libusb:1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
- [[ ${PV} == "9999" ]] && eautoreconf
+ [[ ${PV} == *9999 ]] && eautoreconf
}