summaryrefslogtreecommitdiff
path: root/app-mobilephone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-19 00:32:54 +0000
commit434fbe89e81a1fe06d92676be72ab7f862cc3f53 (patch)
tree7ed0f70fded2af7cbc43e42097f4cd2cebd8c845 /app-mobilephone
parentcd0d9000770337b445051f1852fe3971ceb7a6e2 (diff)
gentoo auto-resync : 19:03:2023 - 00:32:54
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/Manifest.gzbin2046 -> 2210 bytes
-rw-r--r--app-mobilephone/adebar/Manifest3
-rw-r--r--app-mobilephone/adebar/adebar-2.4.1.ebuild64
-rw-r--r--app-mobilephone/adebar/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/app-mobilephone/Manifest.gz b/app-mobilephone/Manifest.gz
index 17e07efab827..eb5a9bd1e676 100644
--- a/app-mobilephone/Manifest.gz
+++ b/app-mobilephone/Manifest.gz
Binary files differ
diff --git a/app-mobilephone/adebar/Manifest b/app-mobilephone/adebar/Manifest
new file mode 100644
index 000000000000..864c850f380f
--- /dev/null
+++ b/app-mobilephone/adebar/Manifest
@@ -0,0 +1,3 @@
+DIST adebar-2.4.1.tar.gz 64226 BLAKE2B 88387844779d9ec857b3f23ca397703fd021cfefbbcb0e5e9bfdea04270adf0cb062d0b34035a93248e7574be5a0dc664f839267e8af82b17967b256f9a57dfc SHA512 7fea787157d1a9bde18601a5199fb57ce108545ade80774ad1d70d64aa7263e9da91f9da1dfa15ff17e266ab0fb78bacab2a767b636013a64d5b2a63f20d74d7
+EBUILD adebar-2.4.1.ebuild 1532 BLAKE2B e75accdb06b17f8d54b00e42e8a074086d940e635b5336283997759eed572f8b0809a81c6477c8405e129a231d34e468be088eabcd087e0bb1651cdc28d285c6 SHA512 359c0dc8da2a303f9f711c8c35cd232a0937bbcc02a26e63fadce132165fbaa7c97feb0337d5e614492e0c5198957f74dcd2934991cfe7d134e3adf7e68d976a
+MISC metadata.xml 250 BLAKE2B 263e291b80ac809528385c358c269f8dff0f767def85431b7320036a9febc0e498645fe1c1b43d576abdd90075efc45935c80c82ea69b95b3c5e83575048fcea SHA512 71d9aa01f6a6a6a9c73f15fbda4242fa5b0edda1265fb30b970f7d74aa3e5ccaaeb2c6fb1266303356915a9c5093263ae1c83541fff9027044b86579ed93ddcd
diff --git a/app-mobilephone/adebar/adebar-2.4.1.ebuild b/app-mobilephone/adebar/adebar-2.4.1.ebuild
new file mode 100644
index 000000000000..1577d71816f9
--- /dev/null
+++ b/app-mobilephone/adebar/adebar-2.4.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Android DEvice Backup And Report, using Bash and ADB"
+HOMEPAGE="https://codeberg.org/izzy/Adebar"
+SRC_URI="https://codeberg.org/izzy/Adebar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-util/android-tools
+"
+
+S="${WORKDIR}/${PN}"
+
+DISABLE_AUTOFORMATTING="no"
+DOC_CONTENTS="Please refer to the documentation at https://codeberg.org/izzy/Adebar/wiki.
+You can find example configurations at ${ROOT}/usr/share/doc/${PF}.
+To customize, copy to \${XDG_CONFIG_HOME}/${PN} and edit it to your liking.
+Contrary to the documentation, the Gentoo installation does not allow
+configuration files relative to main program ${PN} installed to /usr/bin.
+So the documentation must be placed in the users home directory."
+
+src_prepare() {
+ default
+
+ sed -i -e 's|\(BINDIR=\).*|\1"/usr/share/adebar"|' ${PN}-cli
+ sed -i -e 's|\(LIBDIR=\).*|\1"/usr/lib/adebar"|' ${PN}-cli
+ sed -i -e '/-d "\$HOME\/\.config\/adebar"/,+2d' ${PN}-cli
+}
+
+src_install() {
+ local libdir=/usr/lib/${PN}
+ local sharedir=/usr/share/${PN}
+
+ newbin ${PN}-cli ${PN}
+
+ insinto ${libdir}
+ doins -r lib/*
+
+ exeinto ${sharedir}/tools
+ doexe tools/*
+ fperms 0644 ${sharedir}/tools/xml2array.php
+
+ insinto ${sharedir}/templates
+ doins -r templates/*
+
+ dodoc -r doc/*
+ dodoc README.md
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-mobilephone/adebar/metadata.xml b/app-mobilephone/adebar/metadata.xml
new file mode 100644
index 000000000000..46861791de00
--- /dev/null
+++ b/app-mobilephone/adebar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+</pkgmetadata>