summaryrefslogtreecommitdiff
path: root/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild')
-rw-r--r--app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild b/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
new file mode 100644
index 000000000000..d74ae6fce9e1
--- /dev/null
+++ b/app-mobilephone/vmoconv/vmoconv-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A tool that converts Siemens phones VMO and VMI audio files to gsm and wav"
+HOMEPAGE="http://triq.net/obex/"
+SRC_URI="http://triq.net/obexftp/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-sound/gsm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-glibc28.patch"
+ epatch "${FILESDIR}/${P}-flags.patch"
+ epatch "${FILESDIR}/${P}-external-libgsm.patch"
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+ eautoreconf
+}
+
+src_install() {
+ dobin src/vmo2gsm src/gsm2vmo src/vmo2wav
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+}