summaryrefslogtreecommitdiff
path: root/app-mobilephone/obexftp/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-mobilephone/obexftp/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-mobilephone/obexftp/files')
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch22
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-config.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch16
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch35
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch11
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch16
7 files changed, 122 insertions, 0 deletions
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000000..caf0611ff071
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-gentoo.patch
@@ -0,0 +1,22 @@
+--- a/obexftp/client.c
++++ b/obexftp/client.c
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+--- a/apps/obexftp.c
++++ b/apps/obexftp.c
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-config.patch b/app-mobilephone/obexftp/files/obexftp-0.24-config.patch
new file mode 100644
index 000000000000..f923a4b0ed2c
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-config.patch
@@ -0,0 +1,11 @@
+--- a/apps/obexftp.c
++++ b/apps/obexftp.c
+@@ -43,8 +43,6 @@
+
+ #include <common.h>
+
+-#include <config.h>
+-
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch b/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch
new file mode 100644
index 000000000000..ff72fff17e7c
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-enable_bluetooth.patch
@@ -0,0 +1,16 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -52,11 +52,13 @@
+ #
+ # some code is only included if bluetooth is available
+ #
++if ( ENABLE_BLUETOOTH )
+ find_package ( Bluetooth )
+ if ( Bluetooth_FOUND )
+ include_directories ( ${Bluetooth_INCLUDE_DIRS} )
+ add_definitions ( -DHAVE_BLUETOOTH -DHAVE_SDP )
+ endif ( Bluetooth_FOUND )
++endif ( ENABLE_BLUETOOTH )
+
+ add_subdirectory ( bfb )
+ add_subdirectory ( multicobex )
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch b/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch
new file mode 100644
index 000000000000..260cfc2d9a56
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-fuse.patch
@@ -0,0 +1,35 @@
+From 2cc82e0ab5a30eaab5461dcc4eed41b095edba3f Mon Sep 17 00:00:00 2001
+From: Hendrik Sattler <post@hendrik-sattler.de>
+Date: Sun, 11 Aug 2013 20:27:29 +0200
+Subject: [PATCH] Install fuse apps
+
+---
+ fuse/CMakeLists.txt | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/fuse/CMakeLists.txt b/fuse/CMakeLists.txt
+index c31a5fc..7d5f7ea 100644
+--- a/fuse/CMakeLists.txt
++++ b/fuse/CMakeLists.txt
+@@ -14,7 +14,6 @@ if ( Fuse_FOUND )
+ ${Fuse_LIBRARIES}
+ )
+
+-
+ add_executable ( obexautofs
+ obexautofs.c
+ )
+@@ -23,4 +22,10 @@ if ( Fuse_FOUND )
+ obexftp
+ ${Fuse_LIBRARIES}
+ )
++
++ install ( TARGETS obexfs obexautofs
++ RUNTIME
++ DESTINATION ${CMAKE_INSTALL_BINDIR}
++ COMPONENT applications
++ )
+ endif ( Fuse_FOUND )
+--
+1.7.1
+
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch b/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch
new file mode 100644
index 000000000000..75a240177182
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-norpath.patch
@@ -0,0 +1,11 @@
+--- obexftp-0.22/swig/perl/Makefile.PL.in.norpath 2007-07-11 21:22:30.000000000 +0200
++++ obexftp-0.22/swig/perl/Makefile.PL.in 2007-08-06 20:17:39.000000000 +0200
+@@ -11,7 +11,7 @@ WriteMakefile(
+ 'INC' => q[-I@top_srcdir@ @CPPFLAGS@],
+ # Default value for LDDLFLAGS is $Config{lddlflags}="-shared -L/usr/local/lib"
+ # but we want rpath to be @libdir@ or @exec_prefix@/lib
+- 'LDDLFLAGS' => q[-shared -Wl,-rpath=@prefix@/lib],
++ 'LDDLFLAGS' => q[-shared],
+ 'LIBS' => q[-L@top_builddir@/obexftp/.libs -lobexftp
+ -L@top_builddir@/multicobex/.libs -lmulticobex
+ -L@top_builddir@/bfb/.libs -lbfb
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch b/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch
new file mode 100644
index 000000000000..ded4a583330f
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-pkgconfig_requires.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,7 +71,7 @@
+ set ( exec_prefix "\${prefix}" )
+ set ( libdir "\${prefix}/${CMAKE_INSTALL_LIBDIR}" )
+ set ( includedir "\${prefix}/${CMAKE_INSTALL_INCLUDEDIR}" )
+-set ( REQUIRES "bluetooth openobex" )
++set ( REQUIRES "bluez openobex" )
+ configure_file (
+ ${CMAKE_CURRENT_SOURCE_DIR}/obexftp.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/obexftp.pc
diff --git a/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch b/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch
new file mode 100644
index 000000000000..24cc46050ab4
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.24-python_sitedir.patch
@@ -0,0 +1,16 @@
+--- a/swig/python/CMakeLists.txt
++++ b/swig/python/CMakeLists.txt
+@@ -40,11 +40,13 @@
+ OUTPUT_VARIABLE PYTHON_PREFIX
+ )
+ file ( TO_CMAKE_PATH "${PYTHON_PREFIX}" PYTHON_PREFIX )
++if ( NOT PYTHON_SITE_DIR )
+ execute_process (
+ COMMAND ${PYTHON_EXECUTABLE} -c
+ "import site, sys; sys.stdout.write(site.getsitepackages()[-1])"
+ OUTPUT_VARIABLE PYTHON_SITE_DIR
+ )
++endif ( PYTHON_SITE_DIR )
+ file ( TO_CMAKE_PATH "${PYTHON_SITE_DIR}" PYTHON_SITE_DIR )
+ string ( REGEX REPLACE "^${PYTHON_PREFIX}/" ""
+ PYTHON_SITE_DIR "${PYTHON_SITE_DIR}"