summaryrefslogtreecommitdiff
path: root/app-mobilephone/ganyremote
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-mobilephone/ganyremote
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-mobilephone/ganyremote')
-rw-r--r--app-mobilephone/ganyremote/Manifest3
-rw-r--r--app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild55
-rw-r--r--app-mobilephone/ganyremote/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/app-mobilephone/ganyremote/Manifest b/app-mobilephone/ganyremote/Manifest
new file mode 100644
index 000000000000..8b8515b351b0
--- /dev/null
+++ b/app-mobilephone/ganyremote/Manifest
@@ -0,0 +1,3 @@
+DIST ganyremote-6.3.3.tar.gz 303612 BLAKE2B 4865e6e4cb94e380e3bea3a4d27eb6ed60d8455bad3b530167a0e1a2aae458e5ead602869f4fba1917bc9887fec7e96393a694a48482fa339abddce48a506e24 SHA512 cfb0d5896c3c4ee575f2d77d17b8f8e13624202100994415147f1ddb2b6c04c179ec4a4b31369830705ae1d0068e50fe0c3a5fd4acc2de6e02ec0a530a0a6182
+EBUILD ganyremote-6.3.3.ebuild 1371 BLAKE2B 79584321fb6bbd5ab7e51401a60b4c87f8cb6eaf2f72c16686dd7031a60ae00c5409966524ded2739c69f8ca24dd476348284b0657356189b0293817dd319706 SHA512 611638025d469c5e66550016adf854c8fdd30cbfc04dbf56230a8b688a29e3c8ced554e60078db5a2e8dec1e44946f45fa3fe91924b46f20358ff44b5c8d3520
+MISC metadata.xml 246 BLAKE2B 68a1356ab3fd727f1ee98428a5d8edc3452c6d510f8d57cecea1b5cf36a2e0dc40b8b32be858421e041e6d2a18d9aebebbbd4c5d59c2ec560b3e36bc34d3c6aa SHA512 d2929e6457c8072e70cff695c72e7f8e0ee0aa0c10f9850143dc37a05df7af66abdc579ceb750b7e3d8bec5ed246744e42501e66058b4bbd5ebbefcffbb6156a
diff --git a/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
new file mode 100644
index 000000000000..d401aa4313b2
--- /dev/null
+++ b/app-mobilephone/ganyremote/ganyremote-6.3.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-r1
+
+DESCRIPTION="Gnome frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.5[bluetooth=]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/ || die
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
+ "${T}"/gettextize -f --no-changelog > /dev/null || die
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i ganyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am || die
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i ganyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/ganyremote
+}
diff --git a/app-mobilephone/ganyremote/metadata.xml b/app-mobilephone/ganyremote/metadata.xml
new file mode 100644
index 000000000000..2df201a28b67
--- /dev/null
+++ b/app-mobilephone/ganyremote/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">anyremote</remote-id>
+ </upstream>
+</pkgmetadata>