summaryrefslogtreecommitdiff
path: root/app-mobilephone/gammu/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-mobilephone/gammu/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-mobilephone/gammu/files')
-rw-r--r--app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch12
-rw-r--r--app-mobilephone/gammu/files/gammu-1.36.8-bashcompdir.patch12
-rw-r--r--app-mobilephone/gammu/files/gammu-skip-locktest.patch12
3 files changed, 36 insertions, 0 deletions
diff --git a/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch b/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch
new file mode 100644
index 000000000000..d7ae0a5b8b10
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.32.0-bashcompdir.patch
@@ -0,0 +1,12 @@
+diff -ruN gammu-1.32.0/contrib/CMakeLists.txt gammu-1.32.0-patched/contrib/CMakeLists.txt
+--- gammu-1.32.0/contrib/CMakeLists.txt 2012-06-27 04:02:27.000000000 -0400
++++ gammu-1.32.0-patched/contrib/CMakeLists.txt 2013-09-17 16:46:22.852164906 -0400
+@@ -85,7 +85,7 @@
+ if (INSTALL_BASH_COMPLETION)
+ install (
+ FILES bash-completion/gammu
+- DESTINATION "/etc/bash_completion.d"
++ DESTINATION "/usr/share/bash-completion/"
+ COMPONENT "bash"
+ )
+ endif (INSTALL_BASH_COMPLETION)
diff --git a/app-mobilephone/gammu/files/gammu-1.36.8-bashcompdir.patch b/app-mobilephone/gammu/files/gammu-1.36.8-bashcompdir.patch
new file mode 100644
index 000000000000..aceef3da9805
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-1.36.8-bashcompdir.patch
@@ -0,0 +1,12 @@
+diff -BurpN gammu-1.36.8.orig/contrib/CMakeLists.txt gammu-1.36.8/contrib/CMakeLists.txt
+--- gammu-1.36.8.orig/contrib/CMakeLists.txt 2015-12-08 13:38:11.000000000 +0300
++++ gammu-1.36.8/contrib/CMakeLists.txt 2016-01-16 15:49:45.870431342 +0300
+@@ -85,7 +85,7 @@ endif (INSTALL_PHP_EXAMPLES)
+ if (INSTALL_BASH_COMPLETION)
+ macro_optional_find_package (BashCompletion)
+ if (NOT BASH_COMPLETION_FOUND)
+- set (BASH_COMPLETION_COMPLETIONSDIR "/etc/bash_completion.d" CACHE PATH "Location of bash_completion.d")
++ set (BASH_COMPLETION_COMPLETIONSDIR "/usr/share/bash-completion/completions" CACHE PATH "Location of bash_completion.d")
+ endif (NOT BASH_COMPLETION_FOUND)
+ install (
+ FILES bash-completion/gammu
diff --git a/app-mobilephone/gammu/files/gammu-skip-locktest.patch b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
new file mode 100644
index 000000000000..a509879d5edb
--- /dev/null
+++ b/app-mobilephone/gammu/files/gammu-skip-locktest.patch
@@ -0,0 +1,12 @@
+diff -Nru tests/CMakeLists.txt tests/CMakeLists.txt
+--- tests/CMakeLists.txt 2009-09-04 10:56:25.000000000 +0200
++++ tests/CMakeLists.txt 2009-09-05 07:46:58.000000000 +0200
+@@ -739,7 +739,7 @@
+
+ # Test for locking, only on !WIN32 and if we can write to lock dir
+ if (NOT WIN32)
+- execute_process(COMMAND test -w /var/lock/ RESULT_VARIABLE VAR_LOCK_WRITABLE)
++ set (VAR_LOCK_WRITABLE 1)
+ if (VAR_LOCK_WRITABLE EQUAL 0)
+ add_executable(locking locking.c)
+ target_link_libraries(locking libGammu)