summaryrefslogtreecommitdiff
path: root/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /app-mobilephone/dfu-util/dfu-util-0.11.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'app-mobilephone/dfu-util/dfu-util-0.11.ebuild')
-rw-r--r--app-mobilephone/dfu-util/dfu-util-0.11.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-mobilephone/dfu-util/dfu-util-0.11.ebuild b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
new file mode 100644
index 000000000000..0f4c6cd5a619
--- /dev/null
+++ b/app-mobilephone/dfu-util/dfu-util-0.11.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://git.code.sf.net/p/dfu-util/dfu-util"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="implements the Host (PC) side of the USB DFU (Device Firmware Upgrade) protocol"
+HOMEPAGE="http://dfu-util.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="virtual/libusb:1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}