summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 07:16:51 +0100
commitbf99f8024d68382f76665735c70ae912331bc2ca (patch)
tree6fa5830f88fa9ddb794b019c25b83a76ec410df4 /app-misc
parentc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (diff)
gentoo auto-resync : 04:10:2022 - 07:16:51
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin49605 -> 49754 bytes
-rw-r--r--app-misc/ola/Manifest3
-rw-r--r--app-misc/ola/metadata.xml23
-rw-r--r--app-misc/ola/ola-0.10.8.ebuild61
4 files changed, 87 insertions, 0 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 4f64c7bb73e8..de52c1a53203 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/ola/Manifest b/app-misc/ola/Manifest
new file mode 100644
index 000000000000..7d2a353ccc0a
--- /dev/null
+++ b/app-misc/ola/Manifest
@@ -0,0 +1,3 @@
+DIST ola-0.10.8.tar.gz 2552023 BLAKE2B b4fa7e36e2b907e8f0ea16ef089607fc223afc543752a03740fd1d525062ea676d2f392bb623804543827d6f5ac6078c469a3edcb4321bca9a454b1c219f9c89 SHA512 78ef8cc7f8e8d0b1d15bbb305d99a589fce82e07e89ca3bf2466bef8cdc1b18f590fc8dcbf29fc5af2349e0721c832f525fd665d62498907554ee742d79cd3d2
+EBUILD ola-0.10.8.ebuild 1371 BLAKE2B d0d0fe64dd2eca39317fb0415e295d8be5e162341b6c59d91657d5bc28f833baca25a9e8b978e9f7b4633bce21373d6ec2e5ec1b319ebf5455a939321f205893 SHA512 97f4f7a53d8fab7802183028f25ee427e26dfc1bf29eefbf673c70fd8ec3e3f8109a72f0e24273881fb51ae0f3e5572c11d2a9c2ff72452151139fd7bdac6733
+MISC metadata.xml 952 BLAKE2B 0cb2bf271a0392eb3117877a478c36e578cd0b05de41d7a60e42b3cefeeea746086d03aad4c2a8301665873dc0587befd56eaa18f37c237607f6c6de68892f0a SHA512 1a1189401e06190e2b0925c01c45afd386cb5d376f25b188446f3d120dfe35641aabae90b4dc3ad559077f82786a1ea0e648239a05beb1e6fe02d54a0eee020e
diff --git a/app-misc/ola/metadata.xml b/app-misc/ola/metadata.xml
new file mode 100644
index 000000000000..fe23c959e3e0
--- /dev/null
+++ b/app-misc/ola/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription>
+ The Open Lighting Architecture is a framework for lighting control information.
+ It supports a range of protocols and over a dozen USB devices. It can run as a
+ standalone service, which is useful for converting signals between protocols,
+ or alternatively using the OLA API, it can be used as the backend for lighting
+ control software. OLA runs on many different platforms including ARM, which
+ makes it a perfect fit for low cost Ethernet to DMX gateways.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">OpenLightingProject/ola</remote-id>
+ </upstream>
+ <use>
+ <flag name="ftdi">Support FTDI devices</flag>
+ <flag name="http">Enable built-in Web UI</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/ola/ola-0.10.8.ebuild b/app-misc/ola/ola-0.10.8.ebuild
new file mode 100644
index 000000000000..e9fa6752713f
--- /dev/null
+++ b/app-misc/ola/ola-0.10.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Open Lighting Architecture, a framework for lighting control information"
+HOMEPAGE="https://www.openlighting.org/ola/"
+SRC_URI="https://github.com/OpenLightingProject/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples ftdi http osc tcmalloc test usb zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/protobuf:=
+ sys-apps/util-linux
+ sys-libs/ncurses
+ ftdi? ( dev-embedded/libftdi:1 )
+ http? ( net-libs/libmicrohttpd:= )
+ osc? ( media-libs/liblo )
+ tcmalloc? ( dev-util/google-perftools:= )
+ usb? ( virtual/libusb:1 )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+ test? (
+ dev-util/cppunit
+ )"
+
+src_prepare() {
+ default
+ # Upstream recommends doing this even for tarball builds
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatal-warnings
+ --with-uucp-lock="/run"
+ $(use_enable examples)
+ $(use_enable ftdi libftdi)
+ $(use_enable http)
+ $(use_enable osc)
+ $(use_enable tcmalloc)
+ $(use_enable test unittests)
+ $(use_enable usb libusb)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}