summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-01 21:05:47 +0000
commit60f657b5e6155f26601c7def7baa11cee72246d0 (patch)
tree25aecda1c8de352c03f653934407abebf384a560 /app-misc
parente523ebcd50638ebe53f8f425d126bfa7385703b5 (diff)
gentoo auto-resync : 01:02:2023 - 21:05:47
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin49758 -> 49935 bytes
-rw-r--r--app-misc/check-jsonschema/Manifest3
-rw-r--r--app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild50
-rw-r--r--app-misc/check-jsonschema/metadata.xml12
-rw-r--r--app-misc/timew/Manifest2
-rw-r--r--app-misc/timew/timew-1.4.2.ebuild36
6 files changed, 65 insertions, 38 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index 24c931b0a0ee..32c273ffb201 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/check-jsonschema/Manifest b/app-misc/check-jsonschema/Manifest
new file mode 100644
index 000000000000..a9f11c5a821e
--- /dev/null
+++ b/app-misc/check-jsonschema/Manifest
@@ -0,0 +1,3 @@
+DIST check-jsonschema-0.21.0.gh.tar.gz 214872 BLAKE2B 0ee013e379523e5a957e745d550c2014872eab9fc3281aad575f92abfada30b7e0853177bd06147b69a81100bf6b987b485342a087830845c32648efc1c7a9a0 SHA512 dd839a9bb104e1fc68e4a7507077dc991dfc9e840f785c4b7024f2838488eb8b8c6a8f7718f0f821981f5b6b23b1d67745948f48db55a0c589395cf43bfdd2a7
+EBUILD check-jsonschema-0.21.0.ebuild 1149 BLAKE2B f2064dfdc869471a6fdf8b946873c631b1723d2ad3b6ba1462a8d3544a02d6b5a8238757d05be2b3eecbcaa5edc98596b4642d3f5af6900fd2a442df8717f649 SHA512 34cd87e8e9534070783b9ee1f9f7349801f05e28c4ae4d68ad4920f77e8fe02abdb5fd2e4d632cabff6b4b949646c75fb39d5ad87a17a3be3ae3f94ad04d3c10
+MISC metadata.xml 403 BLAKE2B d0254150920ea63313734ad154391cf5d61176b56f53f26c2c8d8408ee571ce0fb4fb1383a6c63ec9f2542fdd66c35feee6b4d926f5cee3cf50253458305c346 SHA512 37cf237a2d7fdf5fe238e42a91d14d29fc01c807546a313b605cead57b50eff9a3fb2b66ed65c5aa019a727778356be659a0466cba5bc7f1b3a1bff8be8da42e
diff --git a/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild b/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild
new file mode 100644
index 000000000000..26d7ad3e1777
--- /dev/null
+++ b/app-misc/check-jsonschema/check-jsonschema-0.21.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A CLI and set of pre-commit hooks for jsonschema validation"
+HOMEPAGE="
+ https://pypi.org/project/check-jsonschema/
+ https://github.com/python-jsonschema/check-jsonschema
+"
+SRC_URI="https://github.com/python-jsonschema/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=(
+ README.md
+ CONTRIBUTING.md
+ CHANGELOG.rst
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+python_prepare_all() {
+ # relax deps in setup.cfg
+ sed -r -e 's:([a-zA-Z.-]+)([<>]|==|[<>]=)+.+:\1: ; /importlib-resources/ d' -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/app-misc/check-jsonschema/metadata.xml b/app-misc/check-jsonschema/metadata.xml
new file mode 100644
index 000000000000..0b93e3e929e1
--- /dev/null
+++ b/app-misc/check-jsonschema/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-jsonschema/check-jsonschema</remote-id>
+ <remote-id type="pypi">check-jsonschema</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index b07ee289e364..9ba2cfef978e 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,5 +1,3 @@
-DIST timew-1.4.2.tar.gz 1316841 BLAKE2B c451f37aeb32e999fe2cdca2eb5f234c7424b76f489324d5723a3649da37f53f5094989bdf8d5c2d27f5daa0d75c72ec4a01e3c19b8b064f28e4db82587498b9 SHA512 fe4c3def6b2cd78793dd97a38a61497b3910cd87a3315f826c64893b96a998bf30363f0df1892b74b718d03a279d51c1a636739225e101c5c126794e434076f0
DIST timew-1.4.3.tar.gz 3188726 BLAKE2B ded92b2ba801023e7f6bc59c0fc17ce069c8279ee92f39280c50dabec0a2425b8612f73edf7842abdbb0b21772244eda325512070c091f32d17ff69cfcd844fa SHA512 89c98ad19d3a5ab5d4e02819d79e553cca4e93da99ec02bbf845b96b421cd084f6786de160e90c97854b50da49448472e9a4c7d23e75c8a93ecd67dda768b24a
-EBUILD timew-1.4.2.ebuild 894 BLAKE2B e49b99f272b8cdbf269a889d9aa1184fa8af8f67e849edc8f43cb41fa8190718b8c952a639234537e9ea5a886fa8e9fa02a64a0389bc0018fd0e5bcc08ec6926 SHA512 be5c84043f5e862fa90ffc0c634eb5672396d2c017f812c9d05b1ef89a370d8adc811d4fae78838a95ac15ddee0f72e0324b69e2a4ea569e4b8c49d1c7db75c1
EBUILD timew-1.4.3-r1.ebuild 1002 BLAKE2B 7eb1c039c77f64171f4d04ebcd5f4599a7af210d077a8e2e36a5aa9eeba42f7e7e17fc4b6c207b2b3ee2d4dc803e39b2580fb35d7cfe9d287437c53684278c4f SHA512 c6fd2c0d7d6fca331fad0dece84d47bbc7a91efae08211c504d358884e2998398d6915be19410460268d120a194c3a81fa068df96d94d67197b69a63946156ef
MISC metadata.xml 708 BLAKE2B 3b8781f0aad86446298f0bff09bc9be053865a114227341cbde00586dc678401ceb8ee7a20e6b03dd23c14dda678c882b18174f9d38fc0fa0d2a7260898ae0e6 SHA512 294c6b699e084282feaf9b1409dd12c8cd7aff0757dba80efcb261d68d4e29449a1f708628a6c80ceac819640144fa6a019f869bbe6fef7390d1353f97c8b86f
diff --git a/app-misc/timew/timew-1.4.2.ebuild b/app-misc/timew/timew-1.4.2.ebuild
deleted file mode 100644
index ec2bdffe0327..000000000000
--- a/app-misc/timew/timew-1.4.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Tracks your time from the command line, and generates reports"
-HOMEPAGE="https://timewarrior.net"
-SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-src_configure() {
- local mycmakeargs=(
- -DTIMEW_DOCDIR=share/doc/${PF}
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- dodoc -r ext
- docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
-}
-
-pkg_postinst() {
- elog "To integrate timewarrior with taskwarrior, issue the following commands:"
- elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
- elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
- elog "see https://timewarrior.net/docs/taskwarrior.html"
-}