summaryrefslogtreecommitdiff
path: root/app-misc/wipe/wipe-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/wipe/wipe-2.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/wipe/wipe-2.3.1.ebuild')
-rw-r--r--app-misc/wipe/wipe-2.3.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/wipe/wipe-2.3.1.ebuild b/app-misc/wipe/wipe-2.3.1.ebuild
new file mode 100644
index 000000000000..c53200bc8276
--- /dev/null
+++ b/app-misc/wipe/wipe-2.3.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=3
+
+inherit autotools eutils
+
+DESCRIPTION="Secure file wiping utility based on Peter Gutman's patterns"
+HOMEPAGE="http://wipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wipe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-LDFLAGS.patch
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin wipe || die
+ doman wipe.1 || die
+ dodoc CHANGES README TODO TESTING || die
+}
+
+pkg_postinst() {
+ elog "Note that wipe is useless on journaling filesystems,"
+ elog "such as reiserfs, XFS, or ext3."
+ elog "See documentation for more info."
+}