summaryrefslogtreecommitdiff
path: root/app-misc/wcd/wcd-6.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /app-misc/wcd/wcd-6.0.2.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'app-misc/wcd/wcd-6.0.2.ebuild')
-rw-r--r--app-misc/wcd/wcd-6.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/wcd/wcd-6.0.2.ebuild b/app-misc/wcd/wcd-6.0.2.ebuild
new file mode 100644
index 000000000000..a5b1dabb2ee3
--- /dev/null
+++ b/app-misc/wcd/wcd-6.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
+SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls unicode"
+
+CDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ unicode? ( dev-libs/libunistring )"
+DEPEND="${CDEPEND}
+ app-text/ghostscript-gpl"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ eapply -p2 "${FILESDIR}"/${PN}-6.0.2-gentoo.patch
+ eapply_user
+ tc-export CC
+}
+
+src_compile() {
+ local mycompile="LFS=1"
+ use nls || mycompile+=" ENABLE_NLS="
+ use unicode && mycompile+=" UCS=1 UNINORM=1"
+ emake ${mycompile}
+}
+
+src_install() {
+ local DOCS=( ../README.txt )
+ default
+ emake DESTDIR="${D}" DOTWCD=1 install-profile sysconfdir="/etc"
+}