summaryrefslogtreecommitdiff
path: root/app-misc/wayland-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 21:52:51 +0100
commitfbba40085f5d1591a67b49f5aa48b4071b7560f1 (patch)
tree09e69d990e9c6d078ad475802b8728fa703bac9a /app-misc/wayland-utils
parent42e82780761e75f17a5cc96626558a297782f385 (diff)
gentoo auto-resync : 10:06:2023 - 21:52:51
Diffstat (limited to 'app-misc/wayland-utils')
-rw-r--r--app-misc/wayland-utils/Manifest2
-rw-r--r--app-misc/wayland-utils/wayland-utils-1.2.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/wayland-utils/Manifest b/app-misc/wayland-utils/Manifest
index fe7dc1dad8ec..438e4f723d3e 100644
--- a/app-misc/wayland-utils/Manifest
+++ b/app-misc/wayland-utils/Manifest
@@ -1,3 +1,5 @@
DIST wayland-utils-1.1.0.tar.bz2 14071 BLAKE2B b2726205c8d123a4543aa316928fe2909917f70bbde4318376581c1ec97f658f0d5743a7df091799ef2adce4c962e83aefdc805e25cf1af5429520eddff2918c SHA512 5cd842c286c1960c1f604287826625c23c87306e9e31daba23a65402d4ae0abd0cec4a701c8fb65af2aea6adbcb018660e646939062c51628a65dde41ebd64bf
+DIST wayland-utils-1.2.0.tar.bz2 15169 BLAKE2B 65f1486e4fcaa86e8b113f3342a23fc03b0025932284f2e9471321efcef59db258bc8cf730b3e0daa656c275fe92ef35f1d7fedfb21a7e32fd1b375c6a26a41d SHA512 fcf7c85273b099aa51462302dec89514707bbe162b791db1ba07b6807de5651cee57cf8a6b7fd63365739c967bfb544d89684e9d399677d563d056b0147baa7e
EBUILD wayland-utils-1.1.0.ebuild 666 BLAKE2B 5c81bb6ca195d973526a214ee59354f81fd2067591b8bee28166e1b5b79df3dffdb748c9d87e32d47174ddcc8abd66a68d661ae99fd69c9545ca333eb86413e0 SHA512 ae2ff2b5f2f527847501550f7529b02e38897a54c74290fb9718780c64518e3b0d9df349b4730f2abf0da7e5d3eed9df13c0518550d440ee5876f1b5295f25b7
+EBUILD wayland-utils-1.2.0.ebuild 679 BLAKE2B 176d0d37176268e0422e0b68004417bd8fa916dcc037a40427274351288dcf493b1a9443df19d278585b1662fd5f09bb275d5078582547e673ef17f449610bfb SHA512 414fd589eac192cbbf5647a1c7c6c12027246ab19ca7f04dad64de7a362fb61c299fc77475392d9bf19fb6f8cac319f0db803494ea751b40c3d1d47531fd73bc
MISC metadata.xml 343 BLAKE2B 1245da4d0eed93c9bc6822719c23140406b752f84b3cd55c7787511164f9bffffafaf359b86e9fd14a52dc119d8e77a21cbaff3c4420348fef8a9a7c92430abe SHA512 12684765e5e7d6f51a0b77180e9c7dd354f29515026fd61621d10b65451d2cc007138b14aa3f5adb4a408f8805b866bfca331ca8083d8d1fe11a2d9f6fb1abc6
diff --git a/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
new file mode 100644
index 000000000000..8ed4e3533def
--- /dev/null
+++ b/app-misc/wayland-utils/wayland-utils-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Display information about supported Wayland protocols and current compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wayland/wayland-utils"
+SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/wayland-1.20.0
+ >=x11-libs/libdrm-2.4.109
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="dev-util/wayland-scanner"
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=enabled
+ )
+ meson_src_configure
+}