summaryrefslogtreecommitdiff
path: root/app-misc/vcontrold/vcontrold-0.98.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-12 19:40:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-12 19:40:50 +0100
commit7e662ec84fc13cef513542e4030f47017d030187 (patch)
tree64f1b39bb0a27aa67a40fa470432a93698cd7d75 /app-misc/vcontrold/vcontrold-0.98.11.ebuild
parentb4ef58ede68341d0e00d761505857e965e2b4231 (diff)
gentoo auto-resync : 12:10:2022 - 19:40:50
Diffstat (limited to 'app-misc/vcontrold/vcontrold-0.98.11.ebuild')
-rw-r--r--app-misc/vcontrold/vcontrold-0.98.11.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/vcontrold/vcontrold-0.98.11.ebuild b/app-misc/vcontrold/vcontrold-0.98.11.ebuild
new file mode 100644
index 000000000000..7449624ff874
--- /dev/null
+++ b/app-misc/vcontrold/vcontrold-0.98.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+DEPEND="dev-libs/libxml2:2"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( dev-python/docutils )"
+
+src_prepare() {
+ sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+ > "src/version.h" || die "Setting version failed"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANPAGES="$(usex man)"
+ -DVCLIENT="$(usex vclient)"
+ -DVSIM="$(usex vsim)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doinitd "${FILESDIR}/vcontrold"
+ insinto /etc/vcontrold/
+ doins -r xml
+}