summaryrefslogtreecommitdiff
path: root/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/ttysnoop/ttysnoop-0.12d.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/ttysnoop/ttysnoop-0.12d.ebuild')
-rw-r--r--app-misc/ttysnoop/ttysnoop-0.12d.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/ttysnoop/ttysnoop-0.12d.ebuild b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
new file mode 100644
index 000000000000..f458720b20b4
--- /dev/null
+++ b/app-misc/ttysnoop/ttysnoop-0.12d.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+MY_P="${P}.k26"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to snoop on login tty's through another tty-device or pseudo-tty"
+HOMEPAGE="http://sysd.org/stas/node/35"
+SRC_URI="http://sysd.org/stas/files/active/0/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README snooptab.dist"
+
+src_prepare(){
+ epatch "${FILESDIR}"/pinkbyte_masking.patch
+ epatch "${FILESDIR}"/"${PN}"-makefile.patch
+}
+
+src_compile(){
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /var/spool/ttysnoop
+ fperms o= /var/spool/ttysnoop
+ dodoc ${DOCS}
+ dosbin ttysnoop
+ dosbin ttysnoops
+ doman ttysnoop.8
+ insinto /etc
+ newins snooptab.dist snooptab
+}