summaryrefslogtreecommitdiff
path: root/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-misc/trash-cli/trash-cli-0.22.4.16.ebuild')
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.4.16.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild b/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.4.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}