summaryrefslogtreecommitdiff
path: root/app-misc/tracker/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 04:05:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 04:05:53 +0100
commitd7665b9dae37c3b9a1c72157fdf49c101bd6495e (patch)
tree6346f889dbe3164a49e89d92ec5914494af4b865 /app-misc/tracker/files
parentaffa75f527bf2512b296482bd14bade15f820d6a (diff)
gentoo auto-resync : 16:05:2023 - 04:05:52
Diffstat (limited to 'app-misc/tracker/files')
-rw-r--r--app-misc/tracker/files/3.5.2-build-Define-_GNU_SOURCE-for-gmtime_r.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-misc/tracker/files/3.5.2-build-Define-_GNU_SOURCE-for-gmtime_r.patch b/app-misc/tracker/files/3.5.2-build-Define-_GNU_SOURCE-for-gmtime_r.patch
new file mode 100644
index 000000000000..f60d86c0513a
--- /dev/null
+++ b/app-misc/tracker/files/3.5.2-build-Define-_GNU_SOURCE-for-gmtime_r.patch
@@ -0,0 +1,46 @@
+https://gitlab.gnome.org/GNOME/tracker/-/merge_requests/596
+
+From 4fc04fea1755c3c4f8913877c2c1889779d3d4d1 Mon Sep 17 00:00:00 2001
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Sun, 14 May 2023 09:59:58 +0530
+Subject: [PATCH] build: Define _GNU_SOURCE for gmtime_r
+
+Found while building tracker 3.5.2 with clang 16, which enable
+Wimplicit-function-declaration by default.
+
+Without _GNU_SOURCE defined, tracker would fail in the configure phase
+with Checking if "strftime 4-digit year modifier" runs: DID NOT
+COMPILE error. And investigating the meson log we see
+
+Compiler stderr:
+ /var/tmp/portage/app-misc/tracker-3.5.2/work/tracker-3.5.2-build/meson-private/tmplr2vm6b0/testfile.c:12:5: error: call to undeclared function 'gmtime_r'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+ gmtime_r (&timestamp, &tm);
+
+And a little further up
+
+Command line: clang /var/tmp/portage/app-misc/tracker-3.5.2/work/tracker-3.5.2-build/meson-private/tmplr2vm6b0/testfile.c -o /var/tmp/portage/app-misc/tracker-3.5.2/work/tracker-3.5.2-build/meson-private/tmplr2vm6b0/output.exe -O2 -pipe -march=native -DTRACKER_DEBUG -DG_DISABLE_CAST_CHECKS -D_FILE_OFFSET_BITS=64 -O0 -Werror=implicit-function-declaration -std=c99 -Wl,-O1 -Wl,--as-needed -fuse-ld=lld -rtlib=compiler-rt -unwindlib=libunwind -Wl,--as-needed
+
+Seems like cc.run() doesn't pick up the general compiler args we set
+earlier. We have already set it for the main build, so adding it just
+for the configure test should be fine.
+
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+---
+ meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/meson.build b/meson.build
+index 7b22cb1f9..00af07e6e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -202,6 +202,7 @@ endif
+ # Get an appropriate 4-digit year modifier for strftime
+ ##################################################################
+ result = cc.run('''
++ #define _GNU_SOURCE
+ #include <stdio.h>
+ #include <string.h>
+ #include <time.h>
+--
+2.39.3
+