summaryrefslogtreecommitdiff
path: root/app-misc/tpipe/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 03:14:33 +0100
commit0c764edfecb7e9e124d4669acd98bed09e23b6c0 (patch)
tree2862ab17d2f88cb7c9614b7fbe579f25ae604b8d /app-misc/tpipe/files
parentae1bf373db295b495e1f685d116e3411bf10df0b (diff)
gentoo auto-resync : 01:08:2022 - 03:14:32
Diffstat (limited to 'app-misc/tpipe/files')
-rw-r--r--app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch21
-rw-r--r--app-misc/tpipe/files/tpipe-1.6-makefile.patch32
2 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch b/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..9a8a094f06b7
--- /dev/null
+++ b/app-misc/tpipe/files/tpipe-1.6-Wimplicit-function-declaration.patch
@@ -0,0 +1,21 @@
+--- a/tap.c
++++ b/tap.c
+@@ -94,7 +94,7 @@
+ else
+ n = strtoul(argv[1],NULL,0);
+
+- if (!(n)&&(argv[1] != '\0')) {
++ if (!(n)&&(*argv[1] != '\0')) {
+ fprintf (stderr, "%s: Unreadable integer arg.; Assuming 1.\n",argv[0]);
+ n = 1;
+ }
+--- a/tpipe.c
++++ b/tpipe.c
+@@ -41,6 +41,7 @@
+
+ #include <stdio.h>
+ #include <string.h> /* strcmp() */
++#include <stdlib.h>
+
+ #ifndef VERSION
+ #define VERSION "1.6"
diff --git a/app-misc/tpipe/files/tpipe-1.6-makefile.patch b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
new file mode 100644
index 000000000000..7ec3566b107f
--- /dev/null
+++ b/app-misc/tpipe/files/tpipe-1.6-makefile.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,27 +1,16 @@
+ # Change values of variables to adapt.
+-CC = gcc
+ PRG1 = tpipe
+ OBJS1 = $(PRG1).o
+ PRG2 = tap
+ OBJS2 =$(PRG2).o
+-OPTFLAGS= -ansi -pedantic -O4
+-CFLAGS = -Wall $(OPTFLAGS)
+-LDFLAGS = -L.
++OPTFLAGS= -pedantic
++CFLAGS += -Wall $(OPTFLAGS)
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man/man1
+
+ all: $(PRG1) $(PRG2)
+
+-.c.o:
+- $(CC) -c $(CFLAGS) -o $@ $<
+-
+-$(PRG1): $(OBJS1)
+- $(CC) $(CFLAGS) -o $(PRG1) $(OBJS1) $(LDFLAGS) $(LIBS)
+-
+-$(PRG2): $(OBJS2)
+- $(CC) $(CFLAGS) -o $(PRG2) $(OBJS2) $(LDFLAGS) $(LIBS)
+-
+ clean:
+ rm -f *~ *.o $(PRG1) $(PRG2)
+