summaryrefslogtreecommitdiff
path: root/app-misc/towitoko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/towitoko
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/towitoko')
-rw-r--r--app-misc/towitoko/Manifest4
-rw-r--r--app-misc/towitoko/metadata.xml9
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r2.ebuild39
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r3.ebuild30
4 files changed, 82 insertions, 0 deletions
diff --git a/app-misc/towitoko/Manifest b/app-misc/towitoko/Manifest
new file mode 100644
index 000000000000..99d699d7327a
--- /dev/null
+++ b/app-misc/towitoko/Manifest
@@ -0,0 +1,4 @@
+DIST towitoko-2.0.7.tar.gz 280177 BLAKE2B 0a58abc81a8106415d25d82a9eab4338d8a1cb8dc04b2d7b1d3790ae1c8429d0fdec2641dae68a9f38b3ce9aa9f14fa5ba1fb4fa9281e75e87a308024ba59873 SHA512 e2e21bda3b1dad55dee1cfb4063e114394a21973b4b2409b9dcff1479fc312fb93bf6e634d38e1f7a30e6f835d87af8268a478b534f65c916eeb13d5dbd07b86
+EBUILD towitoko-2.0.7-r2.ebuild 823 BLAKE2B f4246660a93b0230fe1f83c7b0cf8f813dbde49253ddbe6085feb482250eecf19d551ea10cf877e2c51cc50b6c16ed906b0b2c3c55f01fccaa80fe61dd62f7ba SHA512 9b2df0e8bfc47f14dc22d975b5ba96c02ff91fdfb513f6f95b70e1edd220568ab302193f1b83976999c3b452cb0a127bfffc12e492f65cba177cccc98e832774
+EBUILD towitoko-2.0.7-r3.ebuild 674 BLAKE2B 3b505cf5b7d408c6932b6023ca519e6c6672bbac1e6788c943ae2983b9cf9e594612b15432651b0ee357cdd5dd5660db1500c567902c7c278e90c2a5b756e172 SHA512 bdab3d73bd1326a36c8003729945aab452e59f1e61e2016c74043b0dd7d77983fe4c959add096e488c3f8e79160c9145c4b0138963fc5db28188407dbedb9fce
+MISC metadata.xml 278 BLAKE2B 6cb5d9c1e26e7c00636842a387c8b772f44a284cd24fb44e8133edd04d4d37a2fac01d0cf77768b88137ea7ab302554adf4a32e41df5246b2ab01ac21476f8a9 SHA512 4d69e222be58da2fefd590fa9cdfa2dd6e7108c3f663fb0f491d49609b0ebb8e10b4dccf22966d09f83b81074f0543723837b60015e7d4102b7a7085744c770a
diff --git a/app-misc/towitoko/metadata.xml b/app-misc/towitoko/metadata.xml
new file mode 100644
index 000000000000..7fbec1b41d1c
--- /dev/null
+++ b/app-misc/towitoko/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<use>
+ <flag name="moneyplex">Makes libtowitoko work for the moneyplex home banking
+ software</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/towitoko/towitoko-2.0.7-r2.ebuild b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..fb31a59e4793
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+IUSE="moneyplex"
+
+DESCRIPTION="Provides a driver for using Towitoko smartcard readers under UNIX environment"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://www.gentoo.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile() {
+ local myconf
+
+ myconf=""
+ use moneyplex && myconf="${myconf} --disable-atr-check"
+
+ econf \
+ $(use_enable moneyplex win32-com) \
+ ${myconf} || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if ! use moneyplex
+ then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}
diff --git a/app-misc/towitoko/towitoko-2.0.7-r3.ebuild b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
new file mode 100644
index 000000000000..0538c5fd15b7
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Driver for Towitoko smartcard readers"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+
+IUSE="moneyplex"
+
+src_configure() {
+ local myconf
+ use moneyplex && myconf="--disable-atr-check"
+ econf \
+ $(use_enable moneyplex win32-com) \
+ "${myconf}"
+}
+
+pkg_postinst() {
+ if ! use moneyplex; then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}