summaryrefslogtreecommitdiff
path: root/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-21 21:00:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-21 21:00:58 +0100
commit8b2628ad8526c806375e7b157889e4274b70248b (patch)
treeccba8cd56af7e086131454d6062d5d31115791df /app-misc/towitoko/towitoko-2.0.7-r3.ebuild
parentb620fb1b0929ff9657a2588aaa42b85e3021c102 (diff)
gentoo resync : 21.10.2017
Diffstat (limited to 'app-misc/towitoko/towitoko-2.0.7-r3.ebuild')
-rw-r--r--app-misc/towitoko/towitoko-2.0.7-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/towitoko/towitoko-2.0.7-r3.ebuild b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
new file mode 100644
index 000000000000..0538c5fd15b7
--- /dev/null
+++ b/app-misc/towitoko/towitoko-2.0.7-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Driver for Towitoko smartcard readers"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+
+IUSE="moneyplex"
+
+src_configure() {
+ local myconf
+ use moneyplex && myconf="--disable-atr-check"
+ econf \
+ $(use_enable moneyplex win32-com) \
+ "${myconf}"
+}
+
+pkg_postinst() {
+ if ! use moneyplex; then
+ elog "If you want to use the moneyplex home banking software from"
+ elog "http://www.matrica.de"
+ elog "then please re-emerge this package with 'moneyplex' in USE"
+ fi
+}