summaryrefslogtreecommitdiff
path: root/app-misc/toilet/toilet-0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/toilet/toilet-0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/toilet/toilet-0.3.ebuild')
-rw-r--r--app-misc/toilet/toilet-0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/toilet/toilet-0.3.ebuild b/app-misc/toilet/toilet-0.3.ebuild
new file mode 100644
index 000000000000..614b0cac935e
--- /dev/null
+++ b/app-misc/toilet/toilet-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="The Other Implementations letters. Figlet replacement"
+HOMEPAGE="http://caca.zoy.org/wiki/toilet"
+SRC_URI="http://caca.zoy.org/raw-attachment/wiki/${PN}/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/libcaca-0.99_beta18"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:-g -O2 -fno-strength-reduce -fomit-frame-pointer::' \
+ configure || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README TODO
+}