summaryrefslogtreecommitdiff
path: root/app-misc/tmuxp/tmuxp-1.27.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-13 11:06:03 +0100
commitbe8708090362c01c6111c4b76f1e395c14d86e00 (patch)
treebb61ca73e867522450783849eb63c9e1f0ba1730 /app-misc/tmuxp/tmuxp-1.27.0.ebuild
parente93a38d535f2c29b55a5756d2de99425986b0bf3 (diff)
gentoo auto-resync : 13:08:2024 - 11:06:03
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.27.0.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.27.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.27.0.ebuild b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
index e1e8c9e1a030..14ee373e21bb 100644
--- a/app-misc/tmuxp/tmuxp-1.27.0.ebuild
+++ b/app-misc/tmuxp/tmuxp-1.27.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
DISTUTILS_USE_PEP517=poetry
inherit distutils-r1
@@ -25,7 +25,6 @@ BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
>=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
!dev-python/flaky
)
"
@@ -35,6 +34,11 @@ EPYTEST_DESELECT=(
"tests/cli/test_load.py::test_load_zsh_autotitle_warning"
)
+EPYTEST_IGNORE=(
+ # not actually tests, but throws off test collection
+ "tests/fixtures/"
+)
+
distutils_enable_tests pytest
python_test() {