summaryrefslogtreecommitdiff
path: root/app-misc/tmux/tmux-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/tmux/tmux-9999.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
deleted file mode 100644
index 30b2bd54a86b..000000000000
--- a/app-misc/tmux/tmux-9999.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools git-r3 flag-o-matic versionator
-
-DESCRIPTION="Terminal multiplexer"
-HOMEPAGE="https://tmux.github.io/"
-SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b
-vim-syntax? ( https://raw.githubusercontent.com/keith/tmux.vim/95f6126c187667cc7f9c573c45c3b356cf69f4ca/syntax/tmux.vim -> tmux.vim-95f6126c187667cc7f9c573c45c3b356cf69f4ca )"
-EGIT_REPO_URI="https://github.com/tmux/tmux.git"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug selinux utempter vim-syntax kernel_FreeBSD kernel_linux"
-
-CDEPEND="
- dev-libs/libevent:0=
- sys-libs/ncurses:0=
- utempter? (
- kernel_linux? ( sys-libs/libutempter )
- kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
- )"
-
-DEPEND="
- ${CDEPEND}
- virtual/pkgconfig"
-
-RDEPEND="
- ${CDEPEND}
- selinux? ( sec-policy/selinux-screen )
- vim-syntax? (
- || (
- app-editors/vim
- app-editors/gvim
- )
- )"
-
-DOCS=( CHANGES README TODO )
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4-flags.patch"
-
- # usptream fixes (can be removed with next version bump)
-)
-
-S="${WORKDIR}/${P/_/-}"
-
-src_prepare() {
- # bug 438558
- # 1.7 segfaults when entering copy mode if compiled with -Os
- replace-flags -Os -O2
-
- # regenerate aclocal.m4 to support earlier automake versions
- rm -f aclocal.m4 || die
-
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --sysconfdir="${EPREFIX}"/etc
- $(use_enable debug)
- $(use_enable utempter)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- einstalldocs
-
- dodoc example_tmux.conf
- docompress -x /usr/share/doc/${PF}/example_tmux.conf
-}
-
-pkg_postinst() {
- if ! version_is_at_least 1.9a ${REPLACING_VERSIONS:-1.9a}; then
- echo
- ewarn "Some configuration options changed in this release."
- ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
- ewarn
- ewarn "WARNING: After updating to ${P} you will _not_ be able to connect to any"
- ewarn "older, running tmux server instances. You'll have to use an existing client to"
- ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
- ewarn "to temporarily downgrade to access them."
- echo
- fi
-}