summaryrefslogtreecommitdiff
path: root/app-misc/tmux/tmux-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-misc/tmux/tmux-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-misc/tmux/tmux-9999.ebuild')
-rw-r--r--app-misc/tmux/tmux-9999.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/app-misc/tmux/tmux-9999.ebuild b/app-misc/tmux/tmux-9999.ebuild
index 9e9fa7c5e753..0ee80bc4dec7 100644
--- a/app-misc/tmux/tmux-9999.ebuild
+++ b/app-misc/tmux/tmux-9999.ebuild
@@ -1,31 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools flag-o-matic
DESCRIPTION="Terminal multiplexer"
HOMEPAGE="https://tmux.github.io/"
-if [[ "${PV}" == 9999 ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
SRC_URI="https://raw.githubusercontent.com/przepompownia/tmux-bash-completion/678a27616b70c649c6701cae9cd8c92b58cc051b/completions/tmux -> tmux-bash-completion-678a27616b70c649c6701cae9cd8c92b58cc051b"
EGIT_REPO_URI="https://github.com/tmux/tmux.git"
else
- SRC_URI="https://github.com/tmux/tmux/releases/download/$(ver_cut 1-2)/${P/_/-}.tar.gz"
- [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ SRC_URI="https://github.com/tmux/tmux/releases/download/${PV}/${P/_/-}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+ fi
S="${WORKDIR}/${P/_/-}"
fi
LICENSE="ISC"
SLOT="0"
-IUSE="debug selinux utempter vim-syntax"
+IUSE="debug selinux systemd utempter vim-syntax"
DEPEND="
- dev-libs/libevent:0=
- sys-libs/ncurses:0=
+ dev-libs/libevent:=
+ sys-libs/ncurses:=
+ systemd? ( sys-apps/systemd:= )
utempter? ( sys-libs/libutempter )
+ kernel_Darwin? ( dev-libs/libutf8proc:= )
"
BDEPEND="
@@ -36,14 +39,13 @@ BDEPEND="
RDEPEND="
${DEPEND}
selinux? ( sec-policy/selinux-screen )
- vim-syntax? ( app-vim/vim-tmux )"
+ vim-syntax? ( app-vim/vim-tmux )
+"
DOCS=( CHANGES README )
PATCHES=(
- "${FILESDIR}/${PN}-2.4-flags.patch"
-
- # upstream fixes (can be removed with next version bump)
+ "${FILESDIR}"/${PN}-2.4-flags.patch
)
src_prepare() {
@@ -59,8 +61,15 @@ src_configure() {
local myeconfargs=(
--sysconfdir="${EPREFIX}"/etc
$(use_enable debug)
+ $(use_enable systemd)
$(use_enable utempter)
+
+ # For now, we only expose this for macOS, because
+ # upstream strongly encourage it. I'm not sure it's
+ # needed on Linux right now.
+ $(use_enable kernel_Darwin utf8proc)
)
+
econf "${myeconfargs[@]}"
}