summaryrefslogtreecommitdiff
path: root/app-misc/tmux/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/tmux/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/tmux/files')
-rw-r--r--app-misc/tmux/files/tmux-2.0-flags.patch18
-rw-r--r--app-misc/tmux/files/tmux-2.3-flags.patch15
-rw-r--r--app-misc/tmux/files/tmux-2.3-screen_write_copy-fix.patch63
-rw-r--r--app-misc/tmux/files/tmux-2.4-flags.patch15
-rw-r--r--app-misc/tmux/files/tmux.vim1
5 files changed, 112 insertions, 0 deletions
diff --git a/app-misc/tmux/files/tmux-2.0-flags.patch b/app-misc/tmux/files/tmux-2.0-flags.patch
new file mode 100644
index 000000000000..d2c40e04b788
--- /dev/null
+++ b/app-misc/tmux/files/tmux-2.0-flags.patch
@@ -0,0 +1,18 @@
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 63e20b1..a2fec1e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -25,9 +25,8 @@ endif
+ # Set flags for gcc. gcc4 whines abouts silly stuff so it needs slightly
+ # different flags.
+ if IS_GCC
+-CFLAGS += -std=gnu99 -O2
++CFLAGS += -std=gnu99
+ if IS_DEBUG
+-CFLAGS += -g
+ CFLAGS += -Wno-long-long -Wall -W -Wnested-externs -Wformat=2
+ CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
diff --git a/app-misc/tmux/files/tmux-2.3-flags.patch b/app-misc/tmux/files/tmux-2.3-flags.patch
new file mode 100644
index 000000000000..6fa66b508333
--- /dev/null
+++ b/app-misc/tmux/files/tmux-2.3-flags.patch
@@ -0,0 +1,15 @@
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+--- tmux-2.3/Makefile.am
++++ tmux-2.3/Makefile.am
+@@ -23,9 +23,8 @@
+
+ # Set flags for gcc.
+ if IS_GCC
+-CFLAGS += -std=gnu99 -O2
++CFLAGS += -std=gnu99
+ if IS_DEBUG
+-CFLAGS += -g
+ CFLAGS += -Wno-long-long -Wall -W -Wformat=2
+ CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
diff --git a/app-misc/tmux/files/tmux-2.3-screen_write_copy-fix.patch b/app-misc/tmux/files/tmux-2.3-screen_write_copy-fix.patch
new file mode 100644
index 000000000000..b8383274da2a
--- /dev/null
+++ b/app-misc/tmux/files/tmux-2.3-screen_write_copy-fix.patch
@@ -0,0 +1,63 @@
+From 30086e504c8a5389b96b72b81ac8dbefe19e0cf1 Mon Sep 17 00:00:00 2001
+From: nicm <nicm>
+Date: Wed, 5 Oct 2016 22:00:29 +0000
+Subject: [PATCH] screen_write_copy tried to be clever and clear the line if it
+ reached the end of the source, but it was wrong and causes problems that are
+ only showing up now we are more aggressive about skipping redundant screen
+ updates. Remove the optimization entirely as more trouble than it is worth to
+ fix (and it'll have to go when BCE is done anyway).
+
+---
+ screen-write.c | 34 +++++++---------------------------
+ 1 file changed, 7 insertions(+), 27 deletions(-)
+
+diff --git a/screen-write.c b/screen-write.c
+index 3977517..3a1fc8c 100644
+--- a/screen-write.c
++++ b/screen-write.c
+@@ -394,38 +394,18 @@ screen_write_copy(struct screen_write_ctx *ctx, struct screen *src, u_int px,
+ {
+ struct screen *s = ctx->s;
+ struct grid *gd = src->grid;
+- struct grid_line *gl;
+ struct grid_cell gc;
+- u_int xx, yy, cx, cy, ax, bx;
++ u_int xx, yy, cx, cy;
+
+ cx = s->cx;
+ cy = s->cy;
++
+ for (yy = py; yy < py + ny; yy++) {
+- gl = &gd->linedata[yy];
+- if (yy < gd->hsize + gd->sy) {
+- /*
+- * Find start and end position and copy between
+- * them. Limit to the real end of the line then use a
+- * clear EOL only if copying to the end, otherwise
+- * could overwrite whatever is there already.
+- */
+- if (px > gl->cellsize)
+- ax = gl->cellsize;
+- else
+- ax = px;
+- if (px + nx == gd->sx && px + nx > gl->cellsize)
+- bx = gl->cellsize;
+- else
+- bx = px + nx;
+-
+- for (xx = ax; xx < bx; xx++) {
+- grid_get_cell(gd, xx, yy, &gc);
+- screen_write_cell(ctx, &gc);
+- }
+- if (px + nx == gd->sx && px + nx > gl->cellsize)
+- screen_write_clearendofline(ctx);
+- } else
+- screen_write_clearline(ctx);
++ for (xx = px; xx < px + nx; xx++) {
++ grid_get_cell(gd, xx, yy, &gc);
++ screen_write_cell(ctx, &gc);
++ }
++
+ cy++;
+ screen_write_cursormove(ctx, cx, cy);
+ }
diff --git a/app-misc/tmux/files/tmux-2.4-flags.patch b/app-misc/tmux/files/tmux-2.4-flags.patch
new file mode 100644
index 000000000000..5ef82a3fd5e0
--- /dev/null
+++ b/app-misc/tmux/files/tmux-2.4-flags.patch
@@ -0,0 +1,15 @@
+ Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+--- tmux-2.4/Makefile.am
++++ tmux-2.4/Makefile.am
+@@ -17,9 +17,8 @@
+
+ # Set flags for gcc.
+ if IS_GCC
+-AM_CFLAGS += -std=gnu99 -O2
++AM_CFLAGS += -std=gnu99
+ if IS_DEBUG
+-AM_CFLAGS += -g
+ AM_CFLAGS += -Wno-long-long -Wall -W -Wformat=2
+ AM_CFLAGS += -Wmissing-prototypes -Wstrict-prototypes -Wmissing-declarations
+ AM_CFLAGS += -Wwrite-strings -Wshadow -Wpointer-arith -Wsign-compare
diff --git a/app-misc/tmux/files/tmux.vim b/app-misc/tmux/files/tmux.vim
new file mode 100644
index 000000000000..baac50adab16
--- /dev/null
+++ b/app-misc/tmux/files/tmux.vim
@@ -0,0 +1 @@
+au BufNewFile,BufRead .tmux.conf*,tmux.conf* setf tmux