summaryrefslogtreecommitdiff
path: root/app-misc/tkpasman/tkpasman-2.2b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/tkpasman/tkpasman-2.2b.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/tkpasman/tkpasman-2.2b.ebuild')
-rw-r--r--app-misc/tkpasman/tkpasman-2.2b.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/tkpasman/tkpasman-2.2b.ebuild b/app-misc/tkpasman/tkpasman-2.2b.ebuild
new file mode 100644
index 000000000000..d731fe173f99
--- /dev/null
+++ b/app-misc/tkpasman/tkpasman-2.2b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+MY_P="TkPasMan-${PV}"
+
+DESCRIPTION="A useful and reliable personal password manager, written in Tcl/Tk"
+HOMEPAGE="http://www.xs4all.nl/~wbsoft/linux/tkpasman.html"
+SRC_URI="http://www.xs4all.nl/~wbsoft/linux/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-lang/tcl-8.3:0=
+ >=dev-lang/tk-8.3:0="
+RDEPEND="${DEPEND}
+ ssl? ( dev-libs/openssl )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2a-gentoo.patch
+
+ if use ssl; then
+ sed -i "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog TODO WARNING INSTALL
+}