summaryrefslogtreecommitdiff
path: root/app-misc/terminal-colors/terminal-colors-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-misc/terminal-colors/terminal-colors-9999.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-misc/terminal-colors/terminal-colors-9999.ebuild')
-rw-r--r--app-misc/terminal-colors/terminal-colors-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/terminal-colors/terminal-colors-9999.ebuild b/app-misc/terminal-colors/terminal-colors-9999.ebuild
new file mode 100644
index 000000000000..867968e5c559
--- /dev/null
+++ b/app-misc/terminal-colors/terminal-colors-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="A tool to display color charts for 8, 16, 88, and 256 color terminals"
+HOMEPAGE="http://zhar.net/projects/shell/terminal-colors"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eikenb/terminal-colors.git"
+else
+ SRC_URI="https://github.com/eikenb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() { :; }
+
+src_install() {
+ python_foreach_impl python_newscript ${PN} ${PN}
+ einstalldocs
+}