summaryrefslogtreecommitdiff
path: root/app-misc/tek/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-misc/tek/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-misc/tek/files')
-rw-r--r--app-misc/tek/files/tek-1.3.0-makefile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/tek/files/tek-1.3.0-makefile.patch b/app-misc/tek/files/tek-1.3.0-makefile.patch
new file mode 100644
index 000000000000..b04985235e49
--- /dev/null
+++ b/app-misc/tek/files/tek-1.3.0-makefile.patch
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -15,11 +15,10 @@
+
+ SOURCES=gui.cpp ihex.cpp usb.cpp
+
+-CXXFLAGS=-O2 -std=c++11
++CXXFLAGS+=-std=c++11
+
+ tek.lin: $(patsubst %.cpp,%-lin.o,$(SOURCES))
+- $(LIN_CXX) $(CXXFLAGS) $^ `$(LIN_WXCONFIG) --libs` -lusb-1.0 -o $@
+- $(LIN_STRIP) -s $@
++ $(CXX) $(LDFLAGS) $^ `$(WX_CONFIG) --libs` -lusb-1.0 -o $@ $(LIBS)
+
+ tek.mac: $(patsubst %.cpp,%-mac.o,$(SOURCES))
+ $(OSX_CXX) $(CXXFLAGS) $^ `$(OSX_WXCONFIG) --libs --static` -lusb-1.0 -o $@ -v
+@@ -30,7 +29,7 @@
+ $(WIN_STRIP) -s $@
+
+ %-lin.o: %.cpp
+- $(LIN_CXX) -c $(CXXFLAGS) `$(LIN_WXCONFIG) --cxxflags` $(filter %.cpp,$^) -o $@
++ $(CXX) -c $(CXXFLAGS) $(CPPFLAGS) `$(WX_CONFIG) --cxxflags` $(filter %.cpp,$^) -o $@
+
+ %-win.o: %.cpp
+ $(WIN_CXX) -c $(CXXFLAGS) `$(WIN_WXCONFIG) --cxxflags` $(filter %.cpp,$^) -o $@