summaryrefslogtreecommitdiff
path: root/app-misc/tdl/tdl-1.5.2-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /app-misc/tdl/tdl-1.5.2-r3.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'app-misc/tdl/tdl-1.5.2-r3.ebuild')
-rw-r--r--app-misc/tdl/tdl-1.5.2-r3.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-misc/tdl/tdl-1.5.2-r3.ebuild b/app-misc/tdl/tdl-1.5.2-r3.ebuild
new file mode 100644
index 000000000000..5585cf30099c
--- /dev/null
+++ b/app-misc/tdl/tdl-1.5.2-r3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Command line To Do List manager"
+HOMEPAGE="http://www.rc0.org.uk/tdl/"
+SRC_URI="
+ http://www.rpcurnow.force9.co.uk/tdl/${P}.tar.gz
+ https://dev.gentoo.org/~jlec/distfiles/${PN}-screenshot.png.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc readline"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+DEPEND="
+ ${RDEPEND}
+ sys-apps/sed
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-ldflags.patch
+ "${FILESDIR}"/${P}-list.c.patch
+ "${FILESDIR}"/${P}-main.c.patch
+ "${FILESDIR}"/${P}-man.patch
+)
+
+DOCS=( README NEWS tdl.txt "${WORKDIR}"/screenshot.png tdl.html )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_configure() {
+ local myconf=( --prefix=${EPREFIX}/usr )
+
+ if ! use readline; then
+ myconf+=( "${myconf} --without-readline" )
+ sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in || die
+ fi
+
+ sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure || die
+ "${S}"/configure "${myconf[@]}" || die "configure failed"
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake all tdl.info tdl.html tdl.txt
+
+ if use doc; then
+ emake tdl.dvi tdl.ps tdl.pdf
+ fi
+}
+
+src_install() {
+ einstalldocs
+ doinfo tdl.info
+
+ dobin tdl
+ doman tdl.1
+
+ local i
+ for i in tdl{a,l,d,g}
+ do
+ dosym tdl /usr/bin/${i}
+ dosym tdl.1 /usr/share/man/man1/${i}.1
+ done
+
+ if use doc; then
+ dodoc tdl.dvi tdl.ps tdl.pdf
+ fi
+}