summaryrefslogtreecommitdiff
path: root/app-misc/tdl/tdl-1.5.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/tdl/tdl-1.5.2-r2.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/tdl/tdl-1.5.2-r2.ebuild')
-rw-r--r--app-misc/tdl/tdl-1.5.2-r2.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/app-misc/tdl/tdl-1.5.2-r2.ebuild b/app-misc/tdl/tdl-1.5.2-r2.ebuild
deleted file mode 100644
index 3b105616d7c0..000000000000
--- a/app-misc/tdl/tdl-1.5.2-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Command line To Do List manager"
-HOMEPAGE="http://www.rc0.org.uk/tdl/"
-SRC_URI="
- http://www.rpcurnow.force9.co.uk/tdl/${P}.tar.gz
- https://dev.gentoo.org/~jlec/distfiles/${PN}-screenshot.png.tar"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="doc readline"
-
-RDEPEND="
- sys-libs/ncurses
- sys-libs/readline"
-DEPEND="${RDEPEND}
- sys-apps/sed
- sys-apps/texinfo
- doc? ( virtual/texi2dvi )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-ldflags.patch \
- "${FILESDIR}"/${P}-list.c.patch \
- "${FILESDIR}"/${P}-main.c.patch \
- "${FILESDIR}"/${P}-man.patch
-
- tc-export CC
-}
-
-src_configure() {
- local myconf="--prefix=${EPREFIX}/usr"
-
- if ! use readline; then
- myconf="${myconf} --without-readline"
-
- sed -i 's#\($(LIB_READLINE)\)#\1 -lncurses##g' "${S}"/Makefile.in || die
- fi
- sed -i 's#-ltermcap#-lncurses#g' "${S}"/configure || die
-
- # XXX: do not replace with econf.
- "${S}"/configure ${myconf} || die "configure failed, sorry!"
-}
-
-src_compile() {
- emake all tdl.info tdl.html tdl.txt
- use doc && emake tdl.dvi tdl.ps tdl.pdf
-}
-
-src_install() {
- local i
-
- dodoc README NEWS tdl.txt "${WORKDIR}"/screenshot.png
- doinfo tdl.info
- dohtml tdl.html
-
- dobin tdl
- doman tdl.1
-
- for i in tdl{a,l,d,g}
- do
- dosym tdl /usr/bin/${i}
- dosym tdl.1 /usr/share/man/man1/${i}.1
- done
-
- if use doc; then
- dodoc tdl.dvi tdl.ps tdl.pdf
- fi
-}