summaryrefslogtreecommitdiff
path: root/app-misc/srm/srm-1.2.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/srm/srm-1.2.15.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/srm/srm-1.2.15.ebuild')
-rw-r--r--app-misc/srm/srm-1.2.15.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/srm/srm-1.2.15.ebuild b/app-misc/srm/srm-1.2.15.ebuild
new file mode 100644
index 000000000000..c4fef52773d4
--- /dev/null
+++ b/app-misc/srm/srm-1.2.15.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A command-line compatible rm which destroys file contents before unlinking"
+HOMEPAGE="https://sourceforge.net/projects/srm/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="debug"
+
+DEPEND="!app-misc/secure-delete
+ sys-kernel/linux-headers
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.15-cflags.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+pkg_postinst() {
+ ewarn "Please note that srm will not work as expected with any journaled file"
+ ewarn "system (e.g., reiserfs, ext3)."
+ ewarn "See: ${EROOT%/}/usr/share/doc/${PF}/README"
+}