summaryrefslogtreecommitdiff
path: root/app-misc/sphinx/sphinx-2.0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/sphinx/sphinx-2.0.10.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/sphinx/sphinx-2.0.10.ebuild')
-rw-r--r--app-misc/sphinx/sphinx-2.0.10.ebuild100
1 files changed, 0 insertions, 100 deletions
diff --git a/app-misc/sphinx/sphinx-2.0.10.ebuild b/app-misc/sphinx/sphinx-2.0.10.ebuild
deleted file mode 100644
index 8e0c6d4c8562..000000000000
--- a/app-misc/sphinx/sphinx-2.0.10.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils autotools toolchain-funcs
-
-#MY_P=${P/_/-}
-MY_P=${P}-release
-
-# This has been added by Gentoo, to explicitly version libstemmer.
-# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
-# fetched.
-STEMMER_PV="20091122"
-DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
-HOMEPAGE="http://www.sphinxsearch.com/"
-SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz
- stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="debug id64 mysql odbc postgres stemmer test"
-
-RDEPEND="mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:* )
- odbc? ( dev-db/unixODBC )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- test? ( dev-lang/php )"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- if use stemmer; then
- cd "${S}"
- unpack libstemmer_c-${STEMMER_PV}.tgz
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
-
- # drop nasty hardcoded search path breaking Prefix
- # We patch configure directly since otherwise we need to run
- # eautoreconf twice and that causes problems, bug 425380
- sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
-
- # Fix QA compilation warnings.
- sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
-
- pushd api/libsphinxclient || die
- eautoreconf
- popd || die
-}
-
-src_configure() {
- # fix libiconv detection
- use !elibc_glibc && export ac_cv_search_iconv=-liconv
-
- econf \
- --sysconfdir="${EPREFIX}/etc/${PN}" \
- $(use_enable id64) \
- $(use_with debug) \
- $(use_with mysql) \
- $(use_with odbc unixodbc) \
- $(use_with postgres pgsql) \
- $(use_with stemmer libstemmer)
-
- cd api/libsphinxclient || die
- econf STRIP=:
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" || die "emake failed"
-
- emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
-}
-
-src_test() {
- elog "Tests require access to a live MySQL database and may require configuration."
- elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
-
- dodoc doc/*
-
- dodir /var/lib/sphinx
- dodir /var/log/sphinx
-
- newinitd "${FILESDIR}"/searchd.rc searchd
-
- if use test; then
- insinto /usr/share/${PN}
- doins -r test
- fi
-}