summaryrefslogtreecommitdiff
path: root/app-misc/spacenavd/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /app-misc/spacenavd/files
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'app-misc/spacenavd/files')
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch24
-rw-r--r--app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch24
2 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch b/app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch
new file mode 100644
index 000000000000..485aa6c59338
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.7-gcc10.patch
@@ -0,0 +1,24 @@
+From 081182f1675bb69eec58d92698f1ba2f23466d3f Mon Sep 17 00:00:00 2001
+From: John Tsiombikas <nuclear@member.fsf.org>
+Date: Sat, 1 Feb 2020 01:19:14 +0200
+Subject: [PATCH] GCC 10 changes the default from -fcommon to -fno-common, so
+ we need to set it explicitly now. Closes github bug #17.
+
+---
+ Makefile.in | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 9eba102..abf62c9 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -7,7 +7,8 @@ ctl = spnavd_ctl
+
+ CC = gcc
+ INSTALL = install
+-CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -I$(srcdir)/src -I/usr/local/include $(add_cflags)
++CFLAGS = -pedantic -Wall $(dbg) $(opt) -fno-strict-aliasing -fcommon \
++ -I$(srcdir)/src -I/usr/local/include $(add_cflags)
+ LDFLAGS = -L/usr/local/lib $(xlib) $(add_ldflags)
+
+ $(bin): $(obj)
diff --git a/app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch b/app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch
new file mode 100644
index 000000000000..8dbdb7df3151
--- /dev/null
+++ b/app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch
@@ -0,0 +1,24 @@
+From 3168b1dedf88c9026683ed43ea337814003d6802 Mon Sep 17 00:00:00 2001
+From: John Tsiombikas <nuclear@member.fsf.org>
+Date: Sat, 1 Feb 2020 22:08:43 +0200
+Subject: [PATCH] add a USE_X11 ifdef around the call to drop_xinput in
+ src/dev.c to fix non-X11 build. This should fix github issue #19.
+
+---
+ src/dev.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/dev.c b/src/dev.c
+index 8b72932..2074895 100644
+--- a/src/dev.c
++++ b/src/dev.c
+@@ -88,7 +88,9 @@ int init_devices(void)
+ return -1;
+ }
+
++#ifdef USE_X11
+ drop_xinput();
++#endif
+ return 0;
+ }
+