summaryrefslogtreecommitdiff
path: root/app-misc/socnetv/socnetv-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-18 07:56:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-18 07:56:02 +0100
commiteb17cef883968037fcc6177549d44a030f08b69c (patch)
tree50c47314ceabb3efe7efeb72edeecca54b2aa905 /app-misc/socnetv/socnetv-2.2-r1.ebuild
parent5fa0e0c7e62842b1491426c8c6e506f51b6c78e1 (diff)
gentoo auto-resync : 18:10:2022 - 07:56:02
Diffstat (limited to 'app-misc/socnetv/socnetv-2.2-r1.ebuild')
-rw-r--r--app-misc/socnetv/socnetv-2.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/socnetv/socnetv-2.2-r1.ebuild b/app-misc/socnetv/socnetv-2.2-r1.ebuild
new file mode 100644
index 000000000000..3c0c8c58f078
--- /dev/null
+++ b/app-misc/socnetv/socnetv-2.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils
+
+DESCRIPTION="Qt Social Network Visualizer"
+HOMEPAGE="https://socnetv.org/"
+SRC_URI="mirror://sourceforge/socnetv/SocNetV-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-deps.patch )
+
+src_configure() {
+ eqmake5 socnetv.pro
+}
+
+src_install() {
+ default
+ dobin socnetv
+ doicon src/images/socnetv.png
+ domenu ${PN}.desktop
+ if use examples; then
+ insinto /usr/share/${PN}/examples
+ doins nets/*
+ fi
+
+ gzip -d "${S}"/man/${PN}.1.gz || die
+ doman "${S}"/man/${PN}.1
+}