summaryrefslogtreecommitdiff
path: root/app-misc/sleepyhead/sleepyhead-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/sleepyhead/sleepyhead-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/sleepyhead/sleepyhead-9999.ebuild')
-rw-r--r--app-misc/sleepyhead/sleepyhead-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-misc/sleepyhead/sleepyhead-9999.ebuild b/app-misc/sleepyhead/sleepyhead-9999.ebuild
new file mode 100644
index 000000000000..36e00d73fd3d
--- /dev/null
+++ b/app-misc/sleepyhead/sleepyhead-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils git-2 qt4-r2
+DESCRIPTION="Software used to analyze data from CPAP machines"
+HOMEPAGE="https://sourceforge.net/apps/mediawiki/sleepyhead/index.php?title=Main_Page"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+EGIT_REPO_URI="https://github.com/rich0/rich0-sleepyhead.git"
+EGIT_BRANCH="rich-test"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS=""
+
+IUSE="debug"
+
+DEPEND="virtual/opengl:=
+ x11-libs/libX11:=
+ dev-qt/qtcore:4=
+ dev-qt/qtgui:4=
+ dev-qt/qtopengl:4=
+ dev-qt/qtwebkit:4=
+ dev-libs/quazip:=[qt4]"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+git-2_src_unpack
+}
+
+src_prepare() {
+# qt4_src_prepare
+ cd "{$S}"
+# sed -i '1i#define OF(x) x' quazip/ioapi.h quazip/unzip.c quazip/unzip.h \
+# quazip/zip.c quazip/zip.h quazip/zlib.h
+ eqmake4 SleepyHeadQT.pro
+}
+
+src_install() {
+ cd "{$S}"
+ dobin sleepyhead/SleepyHead || die
+ dodoc README || die
+ dodoc sleepyhead/docs/* || die
+}