summaryrefslogtreecommitdiff
path: root/app-misc/sl/sl-5.02.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/sl/sl-5.02.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/sl/sl-5.02.ebuild')
-rw-r--r--app-misc/sl/sl-5.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/sl/sl-5.02.ebuild b/app-misc/sl/sl-5.02.ebuild
new file mode 100644
index 000000000000..223474eab81f
--- /dev/null
+++ b/app-misc/sl/sl-5.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="sophisticated graphical program which corrects your miss typing"
+HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html https://github.com/mtoyoda/sl/"
+SRC_URI="https://github.com/mtoyoda/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Toyoda"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="l10n_ja"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ sed \
+ -e "s/-lncurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" \
+ -i Makefile || die
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+
+ if use l10n_ja; then
+ newman "${PN}.1.ja" "${PN}.ja.1"
+ DOCS+=( README.ja.md )
+ fi
+
+ einstalldocs
+}