summaryrefslogtreecommitdiff
path: root/app-misc/screenfetch/screenfetch-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/screenfetch/screenfetch-3.7.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/screenfetch/screenfetch-3.7.0.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-3.7.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/screenfetch/screenfetch-3.7.0.ebuild b/app-misc/screenfetch/screenfetch-3.7.0.ebuild
new file mode 100644
index 000000000000..204be3c6626d
--- /dev/null
+++ b/app-misc/screenfetch/screenfetch-3.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PN="${PN/f/F}"
+
+DESCRIPTION="Bash Screenshot Information Tool"
+HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ newbin ${PN}-dev ${PN}
+ dodoc CHANGELOG README.mkdn TODO
+}
+
+pkg_postinst() {
+ optfeature "resoluton detection" x11-apps/xdpyinfo
+ optfeature "screenshot taking" media-gfx/scrot
+ optfeature "screenshot uploading" net-misc/curl
+}