summaryrefslogtreecommitdiff
path: root/app-misc/rox-filer/rox-filer-2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /app-misc/rox-filer/rox-filer-2.11.ebuild
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'app-misc/rox-filer/rox-filer-2.11.ebuild')
-rw-r--r--app-misc/rox-filer/rox-filer-2.11.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-misc/rox-filer/rox-filer-2.11.ebuild b/app-misc/rox-filer/rox-filer-2.11.ebuild
index 6b9abf2b53dc..966f2750cf96 100644
--- a/app-misc/rox-filer/rox-filer-2.11.ebuild
+++ b/app-misc/rox-filer/rox-filer-2.11.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit desktop epatch virtualx
+inherit desktop virtualx
DESCRIPTION="ROX-Filer a drag and drop spatial file manager"
-HOMEPAGE="http://rox.sourceforge.net/desktop"
-SRC_URI="mirror://sourceforge/rox/${P}.tar.bz2"
+HOMEPAGE="http://rox.sourceforge.net/desktop/ROX-Filer.html"
+SRC_URI="https://download.sourceforge.net/rox/${P}.tar.bz2"
-LICENSE="GPL-2 LGPL-2"
+LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE=""
COMMON_DEPEND="dev-lang/perl
dev-libs/libxml2:2
@@ -22,13 +21,18 @@ RDEPEND="${COMMON_DEPEND}
x11-misc/shared-mime-info"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
+ sys-devel/gettext"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${P}"/ROX-Filer/src
+S="${WORKDIR}/${P}/ROX-Filer/src"
+
+PATCHES=(
+ "${FILESDIR}/${P}-in-source-build.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
+)
src_prepare() {
- epatch "${FILESDIR}/${P}-in-source-build.patch"
+ default
sed -i -e 's:g_strdup(getenv("APP_DIR")):"/usr/share/rox":' \
main.c || die "sed failed"