summaryrefslogtreecommitdiff
path: root/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild')
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild b/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..351eb554727a
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-1.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-devel/gcc-4.2"
+
+distutils_enable_tests pytest