summaryrefslogtreecommitdiff
path: root/app-misc/recoll
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-misc/recoll
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-misc/recoll')
-rw-r--r--app-misc/recoll/Manifest2
-rw-r--r--app-misc/recoll/recoll-1.28.5.ebuild135
2 files changed, 137 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 4e69e463e57f..5ff9df395e9a 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1,5 +1,7 @@
DIST recoll-1.25.19.tar.gz 2845683 BLAKE2B 745eac2dd3208619e173abba78f1e03186cdb5deb363c30728184a9d826c698d8e088cc0420178754131792f0d933f395a4fdb209a4315888b733a1209644580 SHA512 d56aff810e335f8212b908118de8fe12fc8d8f8341ebc281244c00dfe2216e008c655f4d39955b6c71928a28ea0aea073036fed17be5b80e8443fe6dfbe374f6
DIST recoll-1.27.12.tar.gz 3184471 BLAKE2B 60bcdee44259fa7f8b9decb9258ca0dae4edbf0cee1e8b1353cb59418503f0fcea9b439ecd6352500ff5b4cccfae08fc2a3f7f786fbd096cf18fd21fb809705b SHA512 3701dff056b8200f3b3c1bb2acaa69356c0def00959a0b74c14e1d500bd9e05fc81d82ce8b7db59d7e5b85617a8a7197700031aab65b31e005a4fedeaff59e97
+DIST recoll-1.28.5.tar.gz 3261816 BLAKE2B 6bf9daab0f97ee6fdb4033197d3fa3f4296b2df8a57566195fca3bf170fec621c27e7da00a1a5a8493fbbadca103a0db7b8c3051abe95d5c2aedb7c289c050a5 SHA512 df4c7a5e624933ccc7ce257a767a4621728a4dbcdd5b551b47845ed0fcffdd5a6f7f617a466404c5e8d8b62c81e57986e1f21e01d643899755623a2dc597d712
EBUILD recoll-1.25.19.ebuild 3622 BLAKE2B c2ee8ef951b79a75aabd9a6dd6b1ba89a0998ef2f3e4a737fccadabc3ba705fd6fc771de213a1622b71dd32527a1197ae2c4dd6c83e94e3d57413bd5e1093acc SHA512 7d7338c9c53d1a71b2647ae30e280174e22ba08e7d208ae4e36dbd7e635520bd5fe7956a94f79ced65a6485da57f9ce733eda2b057d4f4f56ef36179b62b286f
EBUILD recoll-1.27.12.ebuild 3641 BLAKE2B 1193fe6ebde83c363a5c74be16fad6546f24dac6ae61bc2a3a54bd8696ba2cd2c20f4e032972e11f04371764c2589c0c79bb6d40f7a650756ed3eca18ac86308 SHA512 6af7438867270c31376b758383875b8d6ab1d20e4e82a73db8295fe628f49705a2d288f5567e19e3ae7925ecd75b4c9ea33156043a7e2807f6f8a4da76112e2d
+EBUILD recoll-1.28.5.ebuild 3653 BLAKE2B 0e1d0748fcd249487bf5fc5c54a78db5105f1e63128762b4e09fca35c78397a4c32ec0dba5e9212642f401a4cfbe722056a5e4bf13bc5831e86c04057e2d1214 SHA512 fac023cb43351ee667123f40b8cf591cbf17988475e43978ae24d8dce83d055f46968ee72c5de1482b30210c964d992b65487e84055ee5d6d8728551c97bada0
MISC metadata.xml 1382 BLAKE2B e0fe8843b74140663aa9eb968ee212ef0fd76bda4dd17b353b8382fcee917f9d47c82c9790ccae260e375d66ff1ef34049130ddab90d89e89819139848341e00 SHA512 b677720fb6be1b93e6fc26360bb4b9c4008bb2908db4cb8a4d10e84312f5b7e2a59a4e67ef2c5c7b410abdb11b80385efc6d2d604445048a9a9a29c97141223c
diff --git a/app-misc/recoll/recoll-1.28.5.ebuild b/app-misc/recoll/recoll-1.28.5.ebuild
new file mode 100644
index 000000000000..1f44395e55f6
--- /dev/null
+++ b/app-misc/recoll/recoll-1.28.5.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils
+
+DESCRIPTION="A personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase chm doc +inotify qt5 session +spell webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/xapian:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_pretend() {
+ if has_version "<app-misc/recoll-1.20"; then
+ elog "Installing ${PV} over an 1.19 index is possible,"
+ elog "but there have been small changes in the way"
+ elog "compound words are indexed. So it is best to reset"
+ elog "the index. The best method to reset the index is to"
+ elog "quit all recoll programs and delete the index directory"
+ elog "rm -rf ~/.recoll/xapiandb, then start recoll or recollindex."
+ fi
+}
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ use doc && dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "In order to extract the full functionality of "
+ elog "recoll, the following packages should be installed "
+ elog "to get the corresponding document support."
+
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}