summaryrefslogtreecommitdiff
path: root/app-misc/realpath/realpath-1.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 19:52:05 +0000
commitb6a0f46f7d2e1e21df70fb32169f7d9de85445f7 (patch)
tree2f1b6f7c25e85d70d737cd66c68673ed58e1108e /app-misc/realpath/realpath-1.18.ebuild
parent9173f73d44f3cbc858477bd71e7680ede7d98e0d (diff)
gentoo auto-resync : 22:12:2023 - 19:52:05
Diffstat (limited to 'app-misc/realpath/realpath-1.18.ebuild')
-rw-r--r--app-misc/realpath/realpath-1.18.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/app-misc/realpath/realpath-1.18.ebuild b/app-misc/realpath/realpath-1.18.ebuild
deleted file mode 100644
index 4c596cd953c7..000000000000
--- a/app-misc/realpath/realpath-1.18.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic prefix
-
-DESCRIPTION="Return the canonicalized absolute pathname"
-HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
-SRC_URI="
- mirror://debian/pool/main/r/${PN}/${PN}_${PV}.tar.gz
- nls? ( mirror://debian/pool/main/r/${PN}/${PN}_${PV}_i386.deb )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="nls"
-
-RDEPEND="
- nls? ( virtual/libintl )"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.17-build.patch
- "${FILESDIR}"/${PN}-1.14-no-po4a.patch
- "${FILESDIR}"/${PN}-1.15-prefix.patch
-)
-
-src_unpack() {
- unpack ${PN}_${PV}.tar.gz
-
- if use nls; then
- # Unpack the .deb file, in order to get the preprocessed man page
- # translations. This way we avoid a dependency on app-text/po4a.
- mkdir deb
- cd deb
- unpack ${PN}_${PV}_i386.deb
- unpack ./data.tar.gz
- fi
-}
-
-src_prepare() {
- if ! use nls ; then
- eapply "${FILESDIR}"/${PN}-1.16-nonls.patch
- fi
-
- default
-
- # Don't compress man pages
- sed -i -e 's:gzip -9f:true:' common.mk || die
-
- eprefixify common.mk
-}
-
-src_compile() {
- tc-export CC
-
- use nls && ! use elibc_glibc && append-libs -lintl
-
- local subdir
- for subdir in src man $(usex nls po ''); do
- emake MAKE_VERBOSE=yes VERSION="${PV}" -C ${subdir}
- done
-}
-
-src_install() {
- emake \
- VERSION="${PV}" \
- SUBDIRS="src man $(usex nls po '')" \
- DESTDIR="${D}" \
- install
-
- newdoc debian/changelog ChangeLog.debian
-
- if use nls; then
- local dir
- for dir in "${WORKDIR}"/deb/usr/share/man/*; do
- [[ -f "${dir}"/man1/realpath.1 ]] || continue
- newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1
- done
- fi
-}