summaryrefslogtreecommitdiff
path: root/app-misc/rdfind/rdfind-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
commitd84be18029b166ee26fe5416098974a8d05b2983 (patch)
tree0fbc3087c3911f2ac23f738e4f43fcc77cc40386 /app-misc/rdfind/rdfind-1.6.0.ebuild
parent4242446a1af7d38662da76b31d2e6254d64706ec (diff)
gentoo auto-resync : 08:07:2023 - 04:18:34
Diffstat (limited to 'app-misc/rdfind/rdfind-1.6.0.ebuild')
-rw-r--r--app-misc/rdfind/rdfind-1.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/rdfind/rdfind-1.6.0.ebuild b/app-misc/rdfind/rdfind-1.6.0.ebuild
new file mode 100644
index 000000000000..9e091ec5ffd3
--- /dev/null
+++ b/app-misc/rdfind/rdfind-1.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Find duplicate files based on their content"
+HOMEPAGE="https://github.com/pauldreik/rdfind"
+SRC_URI="https://rdfind.pauldreik.se/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-libs/nettle:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/autoconf-archive"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_test() {
+ # Bug 840544
+ local -x SANDBOX_PREDICT="${SANDBOX_PREDICT}"
+ addpredict /
+ default
+}