summaryrefslogtreecommitdiff
path: root/app-misc/ranger/ranger-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-misc/ranger/ranger-9999.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-misc/ranger/ranger-9999.ebuild')
-rw-r--r--app-misc/ranger/ranger-9999.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
index 6d89ea92ccb9..ab9b014fc86d 100644
--- a/app-misc/ranger/ranger-9999.ebuild
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
PYTHON_REQ_USE="ncurses"
inherit distutils-r1
@@ -19,11 +19,10 @@ DESCRIPTION="A vim-inspired file manager for the console"
HOMEPAGE="https://ranger.github.io/"
LICENSE="GPL-3"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="virtual/pager"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
src_prepare() {
# use versioned doc path
@@ -32,10 +31,6 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- py.test -v tests/ranger || die "Tests failed under ${EPYTHON}"
-}
-
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "Ranger has many optional dependencies to support enhanced file previews."