summaryrefslogtreecommitdiff
path: root/app-misc/ranger/ranger-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/ranger/ranger-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/ranger/ranger-9999.ebuild')
-rw-r--r--app-misc/ranger/ranger-9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/ranger/ranger-9999.ebuild b/app-misc/ranger/ranger-9999.ebuild
new file mode 100644
index 000000000000..ac8d37af176d
--- /dev/null
+++ b/app-misc/ranger/ranger-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/ranger/ranger.git"
+ inherit git-r3
+else
+ SRC_URI="http://nongnu.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="A vim-inspired file manager for the console"
+HOMEPAGE="http://ranger.nongnu.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="virtual/pager"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ # use versioned doc path
+ sed -i "s|share/doc/ranger|share/doc/${PF}|" setup.py doc/ranger.1 || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Ranger has many optional dependencies to support enhanced file previews."
+ elog "See the README or homepage for more details."
+ fi
+}