summaryrefslogtreecommitdiff
path: root/app-misc/pystopwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/pystopwatch
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/pystopwatch')
-rw-r--r--app-misc/pystopwatch/Manifest5
-rw-r--r--app-misc/pystopwatch/metadata.xml8
-rw-r--r--app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/pystopwatch/Manifest b/app-misc/pystopwatch/Manifest
new file mode 100644
index 000000000000..9bdc4965acf1
--- /dev/null
+++ b/app-misc/pystopwatch/Manifest
@@ -0,0 +1,5 @@
+DIST pystopwatch-2012.12.24.1.tar.xz 14580 SHA256 d74b6b6e5263e40ce45c0333df1f44e618d87a967d02e0c911782b3ebfdd2a94 SHA512 4b3af373356eaafd14caeecb34150fef8e7099120855230dce7c0eabba68f75d497c3cc2eb733a086a02a96ae5feeca1898ba201a5f6f5597dcd32de9c80b3df WHIRLPOOL 6a37b84f9d932e399eb7df3b59fd94b8ab3bb6c698466cdd495bfaf6b494698579f86f8eebf1032a529b3482b225e0cb857d09dcb8f4e7c1fab5d28475daba2e
+EBUILD pystopwatch-2012.12.24.1-r1.ebuild 662 SHA256 85b2e13ebe236c062efa7145436dd887977989a32810fd876fe0f9a3e0b80ec0 SHA512 f77107c57ef88a9e6faaf8a26c024d5ad6e1405c67c3c54ce32cd085da1d7fa023a8d2f6e70277c408117c1c1c48749eabcadf93117666bbc9b3e207e18545e0 WHIRLPOOL 722b527f13609920e13877586ec908599be018f4e603464eeb31962ccf7a0e196df4c1608a3a09d59740d689782d01319bede6f82600593c30acee722d6544d8
+MISC ChangeLog 2803 SHA256 0868189a615304e42779511c949cee8efe522f681f20ea503237eb5ce860cdfc SHA512 391248442a384eb1f9581bb91fb44437170bdba5d124e06d21e4705dcbd99ea4e06a8fd8fa214fd9e974334a537e2d494ed94ad272105427cd51394ba373b1cb WHIRLPOOL d11710e57aff8bb703728f5790434838c6ee719766bd1e99eec2b1067668704c2eb57bcaf47dfa672e6d5970b7acdb1bf17a13913f2a810c604864d09a74d2d9
+MISC ChangeLog-2015 1578 SHA256 f1683b38c9d0e3e51f92855f40d299de0852569f2e045d028fdf9f7f80758383 SHA512 9c1b6aa9c10c2c70bd59daa9d9f0bfe42d197a88fa431030422aeaa6a17fbc118ed5e2b910adff3e0e35d5953893402e7dc0a8cf9e30b2d657901a16b1fc49da WHIRLPOOL 6d822d76899d139e20f8ddf11cea0b30e0f1950ae8747dc52bf3651f5bfbc932ee0ded856a923b748a7ad195cddba65977f913b1cd234dc36c7719bc3986bc3c
+MISC metadata.xml 237 SHA256 ffb571839c57797d282263369646d2bba2662601a45f7bb3251bb97f716554a6 SHA512 ae2360aa6b1b00c67e0acea4935c02b64585b9a15e126fec9d5d99637021c542c0a495e5116205f3da287def46fa5b19cb1a7f3042c12c5f7a78d66d92fcb03f WHIRLPOOL 60d6da846c983457e038ea5ba3c0bf48f939c9586610985a14cac9772fd1d45d781a643abc16482f232f3028e44fe99fe1a382deaebf6589602fc244a4460e3f
diff --git a/app-misc/pystopwatch/metadata.xml b/app-misc/pystopwatch/metadata.xml
new file mode 100644
index 000000000000..a535b8852829
--- /dev/null
+++ b/app-misc/pystopwatch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild b/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild
new file mode 100644
index 000000000000..8ef9462053b8
--- /dev/null
+++ b/app-misc/pystopwatch/pystopwatch-2012.12.24.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="clock and two countdown functions that can minimize to the tray"
+HOMEPAGE="http://xyne.archlinux.ca/projects/pystopwatch"
+SRC_URI="http://xyne.archlinux.ca/projects/${PN}/src/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ gnome-base/librsvg
+ ${PYTHON_DEPS}
+"
+DEPEND=""
+
+src_prepare() {
+ unpack ./man/${PN}.1.gz
+}
+
+src_install() {
+ python_doscript ${PN}
+ doman ${PN}.1
+}