summaryrefslogtreecommitdiff
path: root/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/pipeworks/pipeworks-0.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/pipeworks/pipeworks-0.4-r1.ebuild')
-rw-r--r--app-misc/pipeworks/pipeworks-0.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/pipeworks/pipeworks-0.4-r1.ebuild b/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
new file mode 100644
index 000000000000..2d278167ebec
--- /dev/null
+++ b/app-misc/pipeworks/pipeworks-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small utility that measures throughput between stdin and stdout"
+HOMEPAGE="http://pipeworks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin pipeworks || die "dobin failed"
+ doman pipeworks.1
+ dodoc Changelog README
+}