summaryrefslogtreecommitdiff
path: root/app-misc/pip3line
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-misc/pip3line
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-misc/pip3line')
-rw-r--r--app-misc/pip3line/Manifest6
-rw-r--r--app-misc/pip3line/metadata.xml17
-rw-r--r--app-misc/pip3line/pip3line-3.5.4.ebuild87
-rw-r--r--app-misc/pip3line/pip3line-3.5.5.ebuild87
-rw-r--r--app-misc/pip3line/pip3line-9999.ebuild87
5 files changed, 284 insertions, 0 deletions
diff --git a/app-misc/pip3line/Manifest b/app-misc/pip3line/Manifest
new file mode 100644
index 000000000000..eea7d2269a4d
--- /dev/null
+++ b/app-misc/pip3line/Manifest
@@ -0,0 +1,6 @@
+DIST pip3line-3.5.4.tar.gz 732872 BLAKE2B e544a2e1af958f3b1ef2e523d8489c807976523109ef8cc73f2c43b543ba9bd0b48d49009637d386e69f7768db6e2bd5a8f098d30dbd199a0b3d6bdaf782c103 SHA512 4a5421e4bf197d8ba2802c3007cfdd4d75a8c356f5bd8774d7f50bb3301e6beb52cc06f7d3486e85c3eaa16d192643afeb00b95e4d174ce16665b509e522ee6a
+DIST pip3line-3.5.5.tar.gz 733385 BLAKE2B e9577fb02d778b689d1c3f5849f714b7d27a5ad49a7a68e412a19cb8251e7ca1d76d0a046bfe10db2257593ccba4f1aa5fff0f34c317975f75ef347f50172088 SHA512 95cbc567f1a7f2bcbc07fe7d560829d9538c126a2748b762fcf505bad47926376abea9d8eaba8670f4c3826b988ea1ea1338faf625a6cdf8db17f457af4edbbb
+EBUILD pip3line-3.5.4.ebuild 2122 BLAKE2B 9beb7ed20f5dce846dfb4bbd53855f8bffb8734add768cbf242dab4214e4ce705d3068a7febfea7df3be886b855bf8b9faee9d0e8541dd886d800db5b2f32029 SHA512 0a7aec8d9893f2e9d853ce077bb54b442b4f9d4482a183fe985650bea614455ddfd8670ba2853cfc25be5065422c8d40c36a124d1930c274270b6e7ed7c47517
+EBUILD pip3line-3.5.5.ebuild 2122 BLAKE2B 9beb7ed20f5dce846dfb4bbd53855f8bffb8734add768cbf242dab4214e4ce705d3068a7febfea7df3be886b855bf8b9faee9d0e8541dd886d800db5b2f32029 SHA512 0a7aec8d9893f2e9d853ce077bb54b442b4f9d4482a183fe985650bea614455ddfd8670ba2853cfc25be5065422c8d40c36a124d1930c274270b6e7ed7c47517
+EBUILD pip3line-9999.ebuild 2122 BLAKE2B 9beb7ed20f5dce846dfb4bbd53855f8bffb8734add768cbf242dab4214e4ce705d3068a7febfea7df3be886b855bf8b9faee9d0e8541dd886d800db5b2f32029 SHA512 0a7aec8d9893f2e9d853ce077bb54b442b4f9d4482a183fe985650bea614455ddfd8670ba2853cfc25be5065422c8d40c36a124d1930c274270b6e7ed7c47517
+MISC metadata.xml 617 BLAKE2B bf8ccd6ecd2783621a6e1c91c216afdf58ae3f4957541fe830fc3a39478331535b50097ae30f51d4ce305cf013cd613b45e3fca41d93b00f0e9a468c3f7b6346 SHA512 49298f62bc28cf669a9308741352fb510a1e7c5ba3749bfe6a9cb284e0ae35be27f672c404c194719440d68c2667f7ac58bb134335c5c95937c1b2e1d5f9e94e
diff --git a/app-misc/pip3line/metadata.xml b/app-misc/pip3line/metadata.xml
new file mode 100644
index 000000000000..9cc54c99226b
--- /dev/null
+++ b/app-misc/pip3line/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gabriel.caudrelier@gmail.com</email>
+ <name>Gabriel Caudrelier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name='distorm'>Compile the Distorm plugin</flag>
+ <flag name='qscintilla'>Use QScintilla for more efficient text display</flag>
+ <flag name='ssl'>Compile the plugin adding miscellaneous hashes from OpenSSL</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-misc/pip3line/pip3line-3.5.4.ebuild b/app-misc/pip3line/pip3line-3.5.4.ebuild
new file mode 100644
index 000000000000..9789c01998c4
--- /dev/null
+++ b/app-misc/pip3line/pip3line-3.5.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
+HOMEPAGE="https://github.com/metrodango/pip3line"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# A few comments
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# It has nothing to do with the SSL/TLS protocol itself.
+
+IUSE="distorm python qscintilla ssl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ qscintilla? ( x11-libs/qscintilla )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ distorm? ( dev-vcs/git )"
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DBASIC=yes
+ -DWITH_DISTORM=$(usex distorm)
+ -DWITH_OPENSSL=$(usex ssl)
+ -DWITH_SCINTILLA=$(usex qscintilla)
+ )
+
+ # distorm is statically linked, due to insufficiencies
+ # in the current distorm64 package
+
+ if use distorm; then
+ mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
+ fi
+
+ if use python; then
+ local targets=( ${PYTHON_TARGETS} )
+ for target in ${targets[@]}; do
+ if python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ for target in ${targets[@]}; do
+ if ! python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON27=ON
+ -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-misc/pip3line/pip3line-3.5.5.ebuild b/app-misc/pip3line/pip3line-3.5.5.ebuild
new file mode 100644
index 000000000000..9789c01998c4
--- /dev/null
+++ b/app-misc/pip3line/pip3line-3.5.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
+HOMEPAGE="https://github.com/metrodango/pip3line"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# A few comments
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# It has nothing to do with the SSL/TLS protocol itself.
+
+IUSE="distorm python qscintilla ssl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ qscintilla? ( x11-libs/qscintilla )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ distorm? ( dev-vcs/git )"
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DBASIC=yes
+ -DWITH_DISTORM=$(usex distorm)
+ -DWITH_OPENSSL=$(usex ssl)
+ -DWITH_SCINTILLA=$(usex qscintilla)
+ )
+
+ # distorm is statically linked, due to insufficiencies
+ # in the current distorm64 package
+
+ if use distorm; then
+ mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
+ fi
+
+ if use python; then
+ local targets=( ${PYTHON_TARGETS} )
+ for target in ${targets[@]}; do
+ if python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ for target in ${targets[@]}; do
+ if ! python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON27=ON
+ -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/app-misc/pip3line/pip3line-9999.ebuild b/app-misc/pip3line/pip3line-9999.ebuild
new file mode 100644
index 000000000000..9789c01998c4
--- /dev/null
+++ b/app-misc/pip3line/pip3line-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
+HOMEPAGE="https://github.com/metrodango/pip3line"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# A few comments
+# the ssl flag is just there to enable the plugin for low level crypto algorithms.
+# It has nothing to do with the SSL/TLS protocol itself.
+
+IUSE="distorm python qscintilla ssl"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxmlpatterns:5
+ qscintilla? ( x11-libs/qscintilla )
+ ssl? ( dev-libs/openssl:0= )"
+
+DEPEND="${RDEPEND}
+ distorm? ( dev-vcs/git )"
+
+src_configure() {
+
+ local mycmakeargs=(
+ -DBASIC=yes
+ -DWITH_DISTORM=$(usex distorm)
+ -DWITH_OPENSSL=$(usex ssl)
+ -DWITH_SCINTILLA=$(usex qscintilla)
+ )
+
+ # distorm is statically linked, due to insufficiencies
+ # in the current distorm64 package
+
+ if use distorm; then
+ mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
+ fi
+
+ if use python; then
+ local targets=( ${PYTHON_TARGETS} )
+ for target in ${targets[@]}; do
+ if python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON3=ON
+ -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ for target in ${targets[@]}; do
+ if ! python_is_python3 ${target}; then
+ python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
+ mycmakeargs+=(-DWITH_PYTHON27=ON
+ -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
+ -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
+ )
+ break
+ fi
+ done
+ fi
+
+ cmake-utils_src_configure
+}