summaryrefslogtreecommitdiff
path: root/app-misc/pip3line
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /app-misc/pip3line
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'app-misc/pip3line')
-rw-r--r--app-misc/pip3line/Manifest4
-rw-r--r--app-misc/pip3line/metadata.xml10
-rw-r--r--app-misc/pip3line/pip3line-3.6.0.ebuild88
-rw-r--r--app-misc/pip3line/pip3line-9999.ebuild88
4 files changed, 0 insertions, 190 deletions
diff --git a/app-misc/pip3line/Manifest b/app-misc/pip3line/Manifest
deleted file mode 100644
index 3dadadd9230f..000000000000
--- a/app-misc/pip3line/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST pip3line-3.6.0.tar.gz 736294 BLAKE2B 75bc3bcd3ad547a31a1fc97f525a8575136ba1bcb48e5e9d7292732c04d2a62cd03710a4e6d76a652d5259e5081cf8cc8c2dfc3265ecf1f3ea5cbc6870c02ab6 SHA512 4263d18749533f1137dc3546a6a5b5856f9c5dc09355c866c7e6a8fc59787c84ee979f648f563c465aab314ff9155bba6e34e7d4641438d96bdb786c93dfaec8
-EBUILD pip3line-3.6.0.ebuild 2156 BLAKE2B 8d357980d5aeaec72fd1001b460a9c7e2a7953517983a9d57d5150f9521cac25bc9fe92a1677e4a83d237131e28be2dc9f045afae34d2bae742bbbfa8e472f23 SHA512 363ea88afc4f7be471fb624a8129e8e195cbcfd557f2615219a49848edc9d49e8e6a2150ec0309fbcb6ec52c6ea8314b73f099ac57f968f2a9c261d7b3155d2a
-EBUILD pip3line-9999.ebuild 2156 BLAKE2B 8d357980d5aeaec72fd1001b460a9c7e2a7953517983a9d57d5150f9521cac25bc9fe92a1677e4a83d237131e28be2dc9f045afae34d2bae742bbbfa8e472f23 SHA512 363ea88afc4f7be471fb624a8129e8e195cbcfd557f2615219a49848edc9d49e8e6a2150ec0309fbcb6ec52c6ea8314b73f099ac57f968f2a9c261d7b3155d2a
-MISC metadata.xml 403 BLAKE2B ffbabd34f0ade6f1c61c98779163c17893dc50c58ab8c1712c6aa36dca531fe346f77d5eb9d6097c53aa0774ce8a8662b477f5c7f06cbdb1b6d99b1ec644103e SHA512 79486243bb6d993f9aaf2ad4b4b2f113d4b88ca5cfad18bf877ef0bc1422d4fb4dac65d5fdcecea3535776255d219e783c5767e16eb45c6109b7441b61c79a12
diff --git a/app-misc/pip3line/metadata.xml b/app-misc/pip3line/metadata.xml
deleted file mode 100644
index a89190752a47..000000000000
--- a/app-misc/pip3line/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <use>
- <flag name='distorm'>Compile the Distorm plugin</flag>
- <flag name='qscintilla'>Use QScintilla for more efficient text display</flag>
- <flag name='ssl'>Compile the plugin adding miscellaneous hashes from OpenSSL</flag>
- </use>
-</pkgmetadata>
diff --git a/app-misc/pip3line/pip3line-3.6.0.ebuild b/app-misc/pip3line/pip3line-3.6.0.ebuild
deleted file mode 100644
index 6bc81c630244..000000000000
--- a/app-misc/pip3line/pip3line-3.6.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
-HOMEPAGE="https://github.com/metrodango/pip3line"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
-# It has nothing to do with the SSL/TLS protocol itself.
-
-IUSE="distorm python qscintilla ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxmlpatterns:5
- qscintilla? ( x11-libs/qscintilla )
- ssl? ( dev-libs/openssl:0= )"
-
-DEPEND="${RDEPEND}
- distorm? ( dev-vcs/git )"
-
-src_configure() {
-
- local mycmakeargs=(
- -DBASIC=yes
- -DWITH_DISTORM=$(usex distorm)
- -DWITH_OPENSSL=$(usex ssl)
- -DWITH_SCINTILLA=$(usex qscintilla)
- )
-
- # distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
-
- if use distorm; then
- mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
- fi
-
- if use python; then
- local targets=( ${PYTHON_TARGETS} )
- for target in ${targets[@]}; do
- if python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- for target in ${targets[@]}; do
- if ! python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON27=ON
- -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- fi
-
- cmake-utils_src_configure
-}
diff --git a/app-misc/pip3line/pip3line-9999.ebuild b/app-misc/pip3line/pip3line-9999.ebuild
deleted file mode 100644
index 6bc81c630244..000000000000
--- a/app-misc/pip3line/pip3line-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
-
-inherit cmake-utils python-r1 python-utils-r1
-
-DESCRIPTION="Raw bytes manipulation, transformations (decoding and more) and interception"
-HOMEPAGE="https://github.com/metrodango/pip3line"
-
-if [[ ${PV} == 9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/metrodango/pip3line.git"
- EGIT_BRANCH="master"
-else
- SRC_URI="https://github.com/metrodango/pip3line/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-# A few comments
-# the ssl flag is just there to enable the plugin for low level crypto algorithms.
-# It has nothing to do with the SSL/TLS protocol itself.
-
-IUSE="distorm python qscintilla ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxmlpatterns:5
- qscintilla? ( x11-libs/qscintilla )
- ssl? ( dev-libs/openssl:0= )"
-
-DEPEND="${RDEPEND}
- distorm? ( dev-vcs/git )"
-
-src_configure() {
-
- local mycmakeargs=(
- -DBASIC=yes
- -DWITH_DISTORM=$(usex distorm)
- -DWITH_OPENSSL=$(usex ssl)
- -DWITH_SCINTILLA=$(usex qscintilla)
- )
-
- # distorm is statically linked, due to insufficiencies
- # in the current distorm64 package
-
- if use distorm; then
- mycmakeargs+=(-DWITH_DISTORM_LINK_STATICALLY=ON)
- fi
-
- if use python; then
- local targets=( ${PYTHON_TARGETS} )
- for target in ${targets[@]}; do
- if python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON3=ON
- -DPYTHON3_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON3_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- for target in ${targets[@]}; do
- if ! python_is_python3 ${target}; then
- python_export ${target} PYTHON PYTHON_LIBPATH PYTHON_INCLUDEDIR
- mycmakeargs+=(-DWITH_PYTHON27=ON
- -DPYTHON27_INCLUDE_DIRS=${PYTHON_INCLUDEDIR}
- -DPYTHON27_LIBRARIES=${PYTHON_LIBPATH}
- )
- break
- fi
- done
- fi
-
- cmake-utils_src_configure
-}