summaryrefslogtreecommitdiff
path: root/app-misc/physlock/physlock-0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-misc/physlock/physlock-0.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-misc/physlock/physlock-0.5.ebuild')
-rw-r--r--app-misc/physlock/physlock-0.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-misc/physlock/physlock-0.5.ebuild b/app-misc/physlock/physlock-0.5.ebuild
new file mode 100644
index 000000000000..f306ba46c194
--- /dev/null
+++ b/app-misc/physlock/physlock-0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}