summaryrefslogtreecommitdiff
path: root/app-misc/pet/pet-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-misc/pet/pet-0.3.0.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/pet/pet-0.3.0.ebuild')
-rw-r--r--app-misc/pet/pet-0.3.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/app-misc/pet/pet-0.3.0.ebuild b/app-misc/pet/pet-0.3.0.ebuild
deleted file mode 100644
index 991478810dcf..000000000000
--- a/app-misc/pet/pet-0.3.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGO_VENDOR=( "github.com/BurntSushi/toml b26d9c308763d68093482582cea63d69be07a0f0"
- "github.com/briandowns/spinner 48dbb65d7bd5c74ab50d53d04c949f20e3d14944"
- "github.com/chzyer/readline f6d7a1f6fbf35bbf9beb80dc63c56a29dcfb759f"
- "github.com/fatih/color 570b54cabe6b8eb0bc2dfce68d964677d63b5260"
- "github.com/google/go-github e48060a28fac52d0f1cb758bc8b87c07bac4a87d"
- "github.com/google/go-querystring 53e6ce116135b80d037921a7fdd5138cf32d7a8a"
- "github.com/inconshreveable/mousetrap 76626ae9c91c4f2a10f34cad8ce83ea42c93bb75"
- "github.com/jroimartin/gocui 4f518eddb04b8f73870836b6d1941e8aa3c06637"
- "github.com/mattn/go-colorable 167de6bfdfba052fa6b2d3664c8f5272e23c9072"
- "github.com/mattn/go-isatty 0360b2af4f38e8d38c7fce2a9f4e702702d73a39"
- "github.com/mattn/go-runewidth 9e777a8366cce605130a531d2cd6363d07ad7317"
- "github.com/nsf/termbox-go 88b7b944be8bc8d8ec6195fca97c5869ba20f99d"
- "github.com/pkg/errors 645ef00459ed84a119197bfb8d8205042c6df63d"
- "github.com/spf13/cobra 7b2c5ac9fc04fc5efafb60700713d4fa609b777b"
- "github.com/spf13/pflag e57e3eeb33f795204c1ca35f56c44f83227c6e66"
- "google.golang.org/appengine 150dc57a1b433e64154302bdc40b6bb8aefa313a github.com/golang/appengine" )
-
-EGO_PN="github.com/knqyf263/${PN}"
-
-inherit golang-build golang-vcs-snapshot
-
-DESCRIPTION="Simple command-line snippet manager"
-HOMEPAGE="https://github.com/knqyf263/pet"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- ${EGO_VENDOR_URI}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="zsh-completion"
-
-# dev-go/toml doesn't provide sources
-DEPEND="dev-go/go-crypto:=
- dev-go/go-net:=
- dev-go/go-oauth2:=
- dev-go/go-protobuf:=
- dev-go/go-sys:="
-RDEPEND="${DEPEND}
- zsh-completion? ( app-shells/zsh-completions )"
-
-src_install() {
- dobin pet
-
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins src/github.com/knqyf263/pet/misc/completions/zsh/_pet
- fi
-}
-
-pkg_postinst() {
- if ! has_version app-shells/peco ; then
- einfo "You should consider to install app-shells/peco"
- einfo "to be able to use selector command"
- fi
-}